Your best friend for file transfer.

Fetch application logoFetch
Fetch Icon Fetch Help > Quick Start

If you are not familiar with FTP or Fetch at all, you may want to read the What is Fetch? and Terms You Should Know help topics to familiarize yourself with terminology commonly used in Fetch and the Fetch Help.

You may also want to read the introductory tutorial, which has illustrated steps that walk you through the process of connecting to a server, navigating around its folders, and transferring a file to and from your Macintosh.

Connecting

When you start Fetch or choose the File > New Connection command, the New Connection dialog appears. You must specify the hostname or IP address of the server you want to connect to (the "host"), either by typing it, or by choosing an item from the Recent Connections or Shortcuts pop-up menus to the right of the hostname field. If required, enter a username and password. Then click the Connect button. In order to use "anonymous FTP," you only need to enter the hostname; Fetch will automatically send the username "anonymous" and a default password. To save this information for easy access later on, choose Make Shortcut from the Shortcuts pop-up menu before clicking the Connect button.

Note: The information entered in the New Connection dialog has nothing to do with your license to use Fetch. It specifies the server with which you are going to transfer files. If you are unsure of the hostname and your username, contact your Internet provider (the company that operates the server in question).

See the New Connection dialog help topic for more information.

Folders (Directories)

Remote computers divide their files among "directories," which are equivalent to folders on the Macintosh. Fetch displays directories as folders, and in Fetch and the Fetch Help they are referred to as folders or "remote folders." Fetch displays remote folders similar to the way the Mac OS Finder displays folders in list view. Once you are connected, the name of the current folder is shown in the title bar of the transfer window. You can change to a different folder in several ways:

  • Double-clicking the name of a folder in the file list (or selecting it and pressing Command-O or Command-Down arrow) will go to that folder.
  • The Path button in the transfer window toolbar displays a pop-up menu that lets you go to any folder that contains the current folder.
  • The Back button in the transfer window toolbar takes you back to the folder you were previously viewing.
  • Choosing the Go > Go to Folder command prompts you for a folder name and, assuming you enter a valid folder name or path and have permission to view that folder, changes to that folder.
  • Finally, the Go menu and the Recent button in the transfer window toolbar list folders you have recently visited on this server. You may quickly return to any of them by choosing one from the menu.

Getting Files

To get (download) a file or folder, select the file and click the Get button in the toolbar. You can also get a file by double-clicking its icon or name.

To get multiple files or folders, click them while holding down the Command or Shift key, and then click the Get button in the toolbar.

You can also get files and folders by dragging them from the Fetch file list to the Finder.

To get a file correctly, Fetch has to communicate with the server in text mode or binary mode. Normally Fetch uses Automatic download mode, in which it decides the mode to use for a file based on its filename extension. However, if you know what kind of file you are getting and Automatic is not picking the correct mode, you can choose the appropriate mode — either Text or Binary — from the Mode submenu in the Remote menu.

By default, Fetch will decode any encoded files, such as BinHex, MacBinary, AppleSingle, or StuffIt files. See the download modes and Transfer Options help topics for more information.

For more information about getting files, see the Get command help topic.

Putting Files

To put (upload) a single file from your Macintosh to another computer, click the Put button in the transfer window toolbar, or choose Put from the Remote menu. You will be prompted to select a file. You can also enter a new name to give to the uploaded file, or choose a different format for uploading the file. Automatic format is the recommended setting, as it will usually pick the correct format for the file. See the upload formats help topic for more information.

To put multiple files or folders, click the Put toolbar button, and then use the Shift and Command keys to select multiple files and folders in the file choice prompt, as you would in the Mac OS Finder.

You can also put files and folders on the remote computer by dragging them from the Finder to a Fetch file list.

For more information about putting files, see the Put command help topic.

Stopping and Quitting

You may stop any ongoing action by clicking the Stop button. Some servers do not recognize the stop command, and will continue the current action until it is completed anyway. In that case, your only options are to close the connection (by closing the transfer window), or quit Fetch by choosing the File > Quit command.

See the Using Fetch section of the help for more guided topics on working with Fetch, or browse the various help sections and use the Help search box to find information.