Your best friend for file transfer.

Fetch application logoFetch
Fetch Icon Fetch Help > What's New > Fetch 5.7 for Fetch 4 Users

Many changes and improvements have been made to Fetch 5.7. If you're a regular Fetch 4 user, this guide should help you find your favorite features in Fetch 5.7. Also be sure to read the summary of new features in Fetch 5.7 to learn about new features that have been added since Fetch 4.

If you're already using Fetch 5, you may want to see the Fetch 5.7 for Fetch 5 Users guide instead.

New Connection Dialog

The New Connection dialog is now modeless — you can use other Fetch windows and most Fetch menu commands while the New Connection dialog is open.

The Shortcuts pop-up menu is now to the right of the Hostname field, and is indicated by a heart icon: . The Create New Shortcut and Create Default Shortcut items have been combined as the Make Shortcut item.

Also next to the hostname field is the new Recent Connections pop-up menu, indicated by a clock icon: . The Recent Connections pop-up lists the last 10 connections you have made.

The new Connect using menu lets you choose the type of connection, including the new SFTP and FTP with TLS/SSL options, which use encryption to protect your password and data. See the connection types help topic for more information.

The new Enable encryption checkbox specifies whether your data will be encrypted as it is transferred. It is always on for SFTP connections, not available for FTP connections, and optional for FTP with TLS/SSL or Kerberos connections.

See the New Connection dialog help topic for more information.

Transfer window

The transfer window has been redesigned with a new layout, a new toolbar, and a file list that works more like the Mac OS Finder's list view.

The Get and Put buttons have moved to the toolbar. The Mode and Format pop-up menus have been removed from the standard transfer window layout, because Fetch's Automatic mode and format should do the right thing almost all the time. However, you can add Mode and Format buttons to the toolbar with the View > Customize Toolbar command. You can also choose a new download mode or upload format from the Remote menu.

Navigating remote folders is easier with the Back and Recent folders buttons in the toolbar. The toolbar also has buttons for several other commonly used Fetch commands. You can add or remove toolbar buttons using the View > Customize Toolbar command, or hide it altogether with the View > Hide Toolbar command. See the transfer window toolbar help topic for more information about the toolbar and the buttons in it.

The progress donut, transfer status, and connection status have been moved to the new, compact status pane beneath the file list. The Stop button is now an icon: .

The path pop-up menu that used to be directly above the file list is now the Path button in the toolbar. (You can also Command-click the transfer window's title.) The name of the current folder, and then either the name of the shortcut matching the current server or the server's hostname, is now displayed in the title bar.

The Parent proxy icon (the little folder in the top left of the Fetch 4 transfer window) has been removed. To create a URL to the current folder, you can drag the proxy icon from the Fetch 5 transfer window's title bar to another application. You can also add a Parent button to the Fetch 5 toolbar with the View > Customize Toolbar command. You can then drag files and folders from the file list to the Parent button to move them to the parent folder.

You can now rename files directly in the file list by clicking once to select an item, and then pressing the Return key to show the edit box. Type a new name or edit the existing name, and press Return again.

Pressing the Return or Enter key no longer downloads the selected file or opens the selected folder; instead it allows you to rename a file. To download a file or open a folder using the keyboard, type Command-Down arrow. You can also open folders by typing Command-O.

See the transfer window and file list help topics for more information about working with the Fetch 5 transfer window.

Putting Files

The interface for uploading multiple files and folders has changed. In Fetch 5, there is a single command for putting files and folders, regardless of whether you are putting one file, one folder, or many files or folders. You do not have to add files and folders to a list to be uploaded as you did in Fetch 4. Instead, in the Put dialog just use the Shift and Command keys to select multiple files and folders. You can also simply drag and drop files and folders to a Fetch transfer window to upload them.

The options for upload format and what to do if files with the same name exist on the server are now in the same dialog that you use for selecting the files and folders, instead of a separate dialog. Fetch now supports resuming interrupted uploads of certain kinds of files; see the resuming uploads help topic.

Fetch 5 supports uploading files as Zip archives, StuffIt archives, and other archive formats.

For more information, see the Put command help topic.

Droplet shortcuts and uploading files using Copy and Paste are new ways to upload files using Fetch 5.

Getting Files

The options for what Fetch should do with files after they've been downloaded, such as which application they should open with, or whether they should be automatically opened or automatically decoded, are now part of the Transfer Options pane of the info window. The Fetch 5 Transfer Options replace the Suffix Mapping and Post-Processing commands and Recognize and Decode preferences of Fetch 4.

To set these options in Fetch 5, select a file whose name ends with an extension for the kind of file that you want to change the behavior of — such as a file ending in .txt for text files — and then choose Remote > Get Info, and go to the Transfer Options pane of the info window.

New to Fetch 5 and later is support for automatic decoding of StuffIt files and other compression and archive formats. Automatic decoding can be disabled for all files in the Download Preferences pane, or just for certain kinds of files in the Transfer Options pane of the info window.

For more information, see the changing the application a file opens with, opening files automatically after downloading, decoding files automatically, and Transfer Options help topics.

Setting Permissions

The Set Permissions command of Fetch 4 has been replaced by the Ownership and Permissions pane of the info window in Fetch 5. To set the permissions of a remote file or folder, select it, choose Remote > Get Info, go to the Ownership and Permissions pane, set the desired permissions, and click the Apply button.

For more information, see the viewing and setting permissions help topic.

Shortcuts and Passwords

Fetch 5.7 stores shortcuts in a different format than Fetch 4, so while you can continue to use Fetch 5.7 and Fetch 4 on the same Macintosh, you may not see changes you make to the Fetch 5.7 shortcuts in the previous versions of Fetch, and vice versa. The first time you open Fetch 5.7, it will automatically read and upgrade your shortcuts from your previous version of Fetch.

While some previous versions of Fetch allowed you to save a shortcut password in the shortcut itself, in Fetch 5.7, all shortcut passwords are saved in your keychain. When you upgrade to Fetch 5.7, your shortcut passwords will be automatically moved to the keychain if they are not stored there already.

The file where Fetch stores your shortcuts has changed. They are now stored in a file named "com.fetchsoftworks.Fetch.Shortcuts.plist" in the Preferences folder in the Library folder in your home folder. Fetch 4 stored shortcuts in a file named "Fetch Shortcuts" in that same location. (After you upgrade, you will have both files — the older file is saved both as a backup, and in case you want to continue to use Fetch 4.)

If you have created separate shortcut list documents in Fetch 4, they will be upgraded to the new format the first time you open them with Fetch 5.7. After they have been upgraded, you cannot use them with earlier versions of Fetch anymore. Fetch does not make a backup during the upgrade, so if you think you may want to continue to use them with an older version of Fetch, please make a backup of your shortcut list documents before opening them in Fetch 5.7.

Menus

Fetch's menus have been extensively reorganized.

The Remote menu has mostly the same commands, but they have been renamed and reorganized.

The Fetch 4 Directories menu has been replaced by the new Go menu, although several commands have been moved to other menus.

Most of the commands from the Fetch 4 Customize menu have been superseded by new features; the shortcut commands have moved to the new Shortcuts menu.

The View Text File and View Media File commands have been replaced by the Quick Look command. The Quick Look command automatically determines what kind of files are selected, and opens the correct type of window. You can use the View as Text command to view a file as plain text, regardless of its contents or extension.

The Edit File with BBEdit and Edit File with GraphicConverter commands have similarly been combined into a single Edit command, and Fetch can now edit any kind of file using any application on your Macintosh, instead of being limited to text and image files and only certain applications. If necessary, hold down the Option key when choosing Edit to select a different application for editing.

Here is a list of all menu commands that have been moved, renamed, or removed. If a menu command is not listed, it retained the same name and location. Select a command name for more information about it.

Old Command Location and Name New Command Location and Name
File > New Shortcut List Shortcuts > New Shortcut List
File > Open Shortcut Listed at bottom of Shortcuts menu
Edit > Set Font and Size View > Set Font and Size
Remote > View Text File Remote > Quick Look or Remote > View as Text
Remote > View Media File Remote > Quick Look
Remote > View File List Remote > View Verbose File List
Remote > Edit File with BBEdit Remote > Edit
Remote > Edit File with GraphicConverter Remote > Edit
Remote > Get Directories and Files Remote > Get
Remote > Put Folders and Files Remote > Put
Remote > Mirror Folder Remote > Mirror
Remote > Rename Directory or File Edit filenames directly in the file list, or use Remote > Get Info
Remote > Delete Directory or File Remote > Delete Item
Remote > Search Use Remote > Send FTP Commands
Remote > Set Permissions Use Remote > Get Info
Remote > Set Upload Permissions Use Remote > Send FTP Commands
Directories > Change Directory Go > Go to Folder
Directories > Create New Directory Remote > New Folder
Directories > Refresh File List View > Refresh
Directories > Clear Directories Menu Go > Clear Menu
Directories > list of recently visited folders Listed at the bottom of the Go menu
Customize > Preferences Fetch > Preferences
Customize > Internet System Preferences No equivalent; go to the System Preferences and choose Network
Customize > Suffix Mappings Select a remote file with the desired extension, choose Remote > Get Info, and use the Transfer Options
Customize > Post-Processing Select a remote file with the desired extension, choose Remote > Get Info, and use the Transfer Options
Customize > Fetch as FTP Helper Use the Default FTP application and Default SFTP application preferences in the General Preferences pane
Customize > New Shortcut Shortcuts > New Shortcut
Customize > Edit Shortcut Shortcuts > Edit Shortcut
Customize > Remove Shortcut Edit > Delete
Window > Fetch Help Help > Fetch Help

Most menu keyboard shortcuts are the same, except for Put, which has changed from Command-T to Command-U; and Change Directory (Command-D) has been replaced by Go To Folder (Command-Shift-G).

Mirror window

In the Mirror window, the pop-up menu at the top of each pane has been replaced with tabs, making it clearer which pane refers to a local folder and which refers to a remote folder. The right hand pane is now remote-only; if you have a saved mirror document that assumed a local pane on the right, it will be switched around automatically when it's opened.

To choose a local folder or remote folder for mirroring in Fetch 5, click the Choose button instead of choosing from the pop-up menu as you did in Fetch 4. To choose a currently open connection as a remote destination in Fetch 5, click the small pop-up menu to the left of the Host label in a Remote pane, again, instead of choosing from the big pop-up menu as you did in Fetch 4.

See the Mirror window help topic for more information.

Fetch Shortcuts

In Fetch 5, the Host and Userid columns have been renamed to Hostname and Username, respectively. The Size and Date columns have been removed, as Fetch 5 no longer tracks that information for shortcuts. The security indicator is now simpler, showing either a locked padlock (secure encrypted connection), an unlocked padlock (securely authenticated, but unencrypted connection), or nothing (not secure). To find out which connection type a secure shortcut uses, you must edit the shortcut.

For more information, see the Fetch Shortcuts and shortcut list window help topics.

AppleScript and Automator

The AppleScript dictionary in Fetch 5 has changed to accommodate new features and changes in the user interface. See the AppleScript changes help topic for more information.

Fetch 5 features a variety of new Automator actions that you can use to create simple workflows that can automate a variety of Fetch tasks.