Your best friend for file transfer.

Fetch application logoFetch
Fetch Icon Fetch Help > Windows > Shortcut List Windows

A shortcut list window collects a group of shortcuts in a single window. This list of shortcuts can be saved and opened again later.

This is a detailed description of shortcut list windows; for a quick guide, see the shortcut list window introduction help topic.

The Fetch Shortcuts window, which Fetch saves and opens automatically, is a shortcut list window. Other shortcut list windows are not saved or reopened automatically, and their shortcuts do not appear in the New Connection dialog or the Shortcuts menu. If you expect to use a shortcut often, you should add it to the Fetch Shortcuts window, not a separate shortcut list window.

To create a shortcut list window, choose Shortcuts > New Shortcut List . You do not need to create the Fetch Shortcuts window, it is created automatically the first time you start Fetch.

To open a shortcut in a shortcut list window, double-click it, or select it and press Command-Down arrow. This will either open the remote folder or start downloading the file it refers to. You can also drag a shortcut to a Finder window or the desktop to start a download. Command-double-click a shortcut to open it in a new transfer window, even if a window to that server is already open.

Uploads can be started by dragging files or folders to a shortcut for the destination. Fetch will automatically open a connection to the location referenced by the shortcut and start the upload.

In a shortcut list window, the three kinds of shortcuts are represented with different icons. Folder or server shortcuts have a folder icon. File shortcuts have a blank document icon. Unknown shortcuts (which may refer to a folder or file) have a combined folder/document icon.

Shortcut list windows have columns listing each shortcut's name, server hostname, security indicator icon (the padlock icon), the username associated with the shortcut (if any), and the path the shortcut refers to (if any). You can sort the shortcuts by clicking any column heading; click the column heading a second time to reverse the sort order.

The security icon indicator will be one of the following: a locked padlock for secure, encrypted connections (SFTP, FTP with TLS/SSL, Kerberos with encryption); an unlocked padlock for connections where your password is sent securely but data transfers won't be encrypted (FTP with TLS/SSL or Kerberos without encryption); and no icon for connections with no security (regular FTP connections). See the padlock icon and security help topics for more information.

You can add shortcuts to a shortcut list window in a number of ways:

  • The Shortcuts > New Shortcut command lets you create a shortcut manually in the active shortcut list window (or in the Fetch Shortcuts window if none are active)
  • The optional New Shortcut button in the transfer window toolbar also lets you create a shortcut in the Fetch Shortcuts window manually.
  • You can drag files or folders from a transfer window into a shortcut list window to create shortcuts for those items.
  • You can drag shortcuts from one shortcut list window into another to copy them to the new window.
  • You can cut or copy shortcuts from one window and paste them into another.
  • You can paste Fetch addresses (FTP URLs) into a shortcut list window.
  • You can drag text Fetch addresses (FTP URLs), for example from an email program or newsreader, into a shortcut list window.
  • If you've set up WebView for a server, you can also paste or drag web addresses (HTTP URLs) for that server into a shortcut list window.

To remove a shortcut from a shortcut list window, select the shortcut and then choose Edit > Delete, press the Delete key, or drag the shortcut to the Mac OS Trash icon.

The entire shortcut list can be saved as a shortcut list document for future use with File > Save or File > Save As, and reopened with File > Open .

To edit a shortcut in a shortcut list window, open the shortcut list window, select the shortcut, and choose Shortcuts > Edit Shortcut . You can also Option-Shift-double-click the shortcut to open the Edit Shortcut dialog.

You can also edit the shortcut's information directly in the shortcut list window by clicking once to select the shortcut, and then clicking again on the piece of information you want to edit. An edit box appears around the text. Edit the text, and press Return to confirm your changes.

Option-double-clicking a shortcut in a shortcut list window brings up the New Connection dialog, filled out with information from the shortcut. You can also do this from the keyboard by selecting a shortcut and pressing Command-Option-Down arrow.

You can access commonly used commands by Control-clicking a shortcut to display the shortcut list window contextual menu. In particular, the contextual menu is the only way to access the Duplicate command, which will make a copy of a shortcut in the same window.

Also see the shortcuts topic for more general information about shortcuts.