Your best friend for file transfer.

Fetch application logoFetch

-3162 error (7 posts)

This is an archived topic. The information in it is likely to be out-of-date and no longer applicable to current versions of Fetch.
  • Started 13 years ago by mpittelli
  • Latest reply 12 years ago from mpittelli
  • mpittelli Member

    We are using Fetch 3.0.3 and Microsoft Proxy Server 2.0, sp1. We have "use passive mode" checked ON; "use proxy ftp server" OFF; use SOCKS gateway" ON, with IP address of proxy server filled in; and "use data ports from 1025 to 65535". This configuration has been consistently working for us. Starting Friday, we have been experiencing a problem with the Fetch dog not moving, and then eventually getting a error box stating "Error number -3162". Pressing OK exits the box. I have already double-checked the Fetch settings by verifying against our documentation and trying another Mac. I have already checked the services on the Proxy server, and rebooted the server. Any other ideas you may have will be greatly appreciated.

    Posted 13 years ago #

  • Jim Matthews Administrator

    Is it possible that you no longer have direct access to a domain name server?

    I would suggest trying Fetch 4.0 and specifying SOCKS 4.3 as the proxy type. It will let the proxy server handle domain name resolution.

    Thanks,

    Jim Matthews
    Fetch Softworks

    Posted 13 years ago #

  • mpittelli Member

    Fetch 4.0x does indeed work...HOWEVER, it will allow us to GET only one file for each session. Upon GETting the second file (or trying a multiple file GET), the program justs continues to run and run and run.

    Posted 12 years ago #

  • Jim Matthews Administrator

    Have you tried both settings of the "Use passive mode transfers (PASV)" checkbox?

    Jim Matthews
    Fetch Softworks

    Posted 12 years ago #

  • mpittelli Member

    Yes, I have tried it both ways. With PASV unchecked, I can logon to sites, but get no file list. With PASV on, I can logon, get file lists, and GET one file.

    Posted 12 years ago #

  • Jim Matthews Administrator

    I'm afraid I'm stumped. I know that some people are having success using 4.0 with MS Proxy 2.0, but you seem to have tried everything that's worked before without any luck. You could ask Microsoft -- I know I'd be very interested to hear what they say.

    Another thing to try is other Mac programs that support SOCKS, such as Interarchy. If they have the same problem it's likely to be a proxy problem rather than a Fetch problem.

    Sorry I can't be of more help,

    Jim Matthews
    Fetch Softworks

    Posted 12 years ago #

  • mpittelli Member

    Thank you for your replies and time. I will update this topic as I work on this...

    Posted 12 years ago #

Topic closed

This topic has been closed.