Your best friend for file transfer.

Fetch application logoFetch

4.02 still has sloooow upload (5 posts)

This is an archived topic. The information in it is likely to be out-of-date and no longer applicable to current versions of Fetch.
  • Started 11 years ago by Red Head
  • Latest reply 11 years ago from Red Head
  • Red Head Member

    Jim et al.,
    I'm trying to upload to a UNIX server. Downloads are fine but uploads beyond about 25 kb stall and usually never finish. File ends up as a 0 kb size on my server. I've tried PASV transfer mode on or off.

    Mac OS 10.1.5

    Jim here's the Fetch transcript of a failed process:
    STOR frontend.swf
    150 Opening BINARY mode data connection for frontend.swf.
    (and then afer 10 minutes with no progress in the "blue wheel")
    426 Data Connection: Connection reset by peer.
    ftp_store_close: -30000 (state == PUT_CLOSING)
    ABOR
    225 ABOR command successful.

    Can you make some suggestions?
    Thanks for all your hard work!
    Red Head

    Posted 11 years ago #

  • Jim Matthews Administrator

    Some questions that come to mind:

    How are you connected to the Internet (modem, cable modem, DSL, router, etc.)?

    Has uploading over this connection ever worked?

    Can you upload to ftp.fetchsoftworks.com? To try, put "ftp.fetchsoftworks.com" in the Host field of the New Connection and leave the User ID and Password fields blank. Once you are connected, enter the "incoming" directory by double-clicking its icon. Ignore the "Permission denied" message that appears in the file list, and upload the file there.

    Thanks,

    Jim Matthews
    Fetch Softworks

    Posted 11 years ago #

  • Red Head Member

    Jim,
    Thanks for the quick response. What excellent support!

    My connection is a G4 Titanium Powerbook internal 56 k modem. The phone line is not great so I mostly use the Apple Internal Modem v.34 modem choice. The connection in Classis mode ( OS 9.2.2) with Fetch 4.02 works fine on upload to your server and mine.

    However, the Fetch 4.0.2 upload to the ftp.fetchsoftworks.com's incoming directory with the OS 10.1.5 failed as it does to my server. Here's the complete transcript file:

    ***
    Fetch 4.0.2 System 0x1015 Serial FETCHED001-2L43-8452 TR
    Connecting to ftp.fetchsoftworks.com port 21 (7/3/02 7:39:31 PM)
    220 smokeworks.com NcFTPd Server (licensed copy) ready.
    ADAT
    500 Syntax error, command unrecognized.
    USER anonymous
    331 Guest login ok, send your complete e-mail address as password.
    PASS
    230-You are user #3 of 16 simultaneous users allowed.
    230-
    230 Logged in anonymously.
    SYST
    215 UNIX Type: L8
    PWD
    257 "/" is cwd.
    MACB ENABLE
    500 Syntax error, command unrecognized.
    PWD
    257 "/" is cwd.
    PASV
    227 Entering Passive Mode (216,92,39,106,228,145)
    LIST -al
    150 Data connection accepted from 158.135.8.63:49191; transfer starting.
    -rw-r--r-- 1 ftpuser ftpusers 1291736 Apr 29 13:36 Fetch_4.0.2.sit
    drwxr-xr-x 2 ftpuser ftpusers 512 Dec 14 2001 example
    drwx-wx-wx 2 ftpuser ftpusers 5120 Jul 2 18:36 incoming
    226 Listing completed.
    CWD incoming
    250 "/incoming" is new cwd.
    PWD
    257 "/incoming" is cwd.
    PASV
    227 Entering Passive Mode (216,92,39,106,228,146)
    LIST -al
    150 Data connection accepted from 158.135.8.63:49192; transfer starting.
    .: Permission denied
    226 Listing completed.
    TYPE L 8
    200 Type okay.
    PASV
    227 Entering Passive Mode (216,92,39,106,228,147)
    STOR frontend.swf
    150 Data connection accepted from 158.135.8.63:49193; transfer starting.
    ftp_store_close: -30014 (state == PUT_CLOSING)
    ABOR
    ***

    It appears that Fetch 4.02 under OS X acts differently. I haven't changed any of the Fetch "obscure setting", in fact ANY Fetch settings between the two OS attempts.

    Any help is appreciated. I'm an Educational user so as a beggar really appreciate your support!

    Red Head

    Originally posted by JimMatthews:

    Some questions that come to mind:

    How are you connected to the Internet (modem, cable modem, DSL, router, etc.)?

    Has uploading over this connection ever worked?

    Can you upload to ftp.fetchsoftworks.com? To try, put "ftp.fetchsoftworks.com" in the Host field of the New Connection and leave the User ID and Password fields blank. Once you are connected, enter the "incoming" directory by double-clicking its icon. Ignore the "Permission denied" message that appears in the file list, and upload the file there.

    Thanks,

    Jim Matthews
    Fetch Softworks

    Posted 11 years ago #

  • Jim Matthews Administrator

    That's pretty odd. Two other things to try on OS X:

    1) Try downloading one of the files on ftp.fetchsoftworks.com (i.e. test whether the problem is limited to uploads).

    2) Try unchecking "Use passive mode transfers (PASV)" in the Firewall section of Preferences.

    Thanks,

    Jim Matthews
    Fetch Softworks

    Posted 11 years ago #

  • Red Head Member

    Downloads worked out OK. Upload problem occurs with or without PASV clicked.

    That said, I've now discovered that the problem doesn't appear to be Fetch per se because RBrowser Lite also suffers from the same slow FTP upload problem.

    This seems like an OS X FTP problem (remember that booting into Classic and using Fetch works great).

    Again, thank for all your hard work.

    Red Head

    Originally posted by JimMatthews:

    That's pretty odd. Two other things to try on OS X:

    1) Try downloading one of the files on ftp.fetchsoftworks.com (i.e. test whether the problem is limited to uploads).

    2) Try unchecking "Use passive mode transfers (PASV)" in the Firewall section of Preferences.

    Thanks,

    Jim Matthews
    Fetch Softworks

    Posted 11 years ago #

Topic closed

This topic has been closed.