Your best friend for file transfer.

Fetch application logoFetch

Applescript auto login, but still get login dialog box (4 posts)

  • Started 9 years ago by skunkworks
  • Latest reply 9 years ago from Scott McGuire
  • skunkworks Member

    I have written an applescript to do a one-click website update (generate the HTML, launch Fetch to upload the file to the required remote site, and quit).

    The applescript contains the full login details required (username and password) for the remote host, but when Fetch launches, the password dialog box comes up anyway, and the applescript is suspended until I have manually entered the password.

    Is there any way to stop this behaviour, and have Fetch automatically login with no dialog boxes? If not, why does the Fetch dictionary allow you to store passwords in a "make new transfer window" command?

    PS. I am fully aware of the security implications of storing a password in an applescript and have fully accepted the risk.

    Brendan.

    Posted 9 years ago #

  • Scott McGuire Administrator

    Hi Brendan,

    Are you using Fetch 4 or Fetch 5? I tried using the "make new transfer window" command with a password property in Fetch 5, and I did not get a password prompt.

    If you uncheck the "Show New Connection dialog at startup" preference in the General pane of the Preferences (or the Misc pane, if you're using Fetch 4), does that help?

    If not, we'll need to take a look at the script (you can replace the password and username with fake info) to try to figure out what's wrong. If you don't feel comfortable posting it here even after removing the username and password, send a message with script and a brief description of the problem to bugs at fetchsoftworks dot com.

    Thanks,

    Scott McGuire
    Fetch Softworks

    Posted 9 years ago #

  • skunkworks Member

    Thanks Scott!

    I am using Fetch 4.0.3 - the problem was "Show New Connection dialog at startup" preference was checked, hence when Fetch launched, the modal dialog appeared.

    Unchecking that preference has fixed it and the script now works a treat!!

    Thanks again.

    Posted 9 years ago #

  • Scott McGuire Administrator

    Great, glad to hear the problem is solved, Brendan.

    Best,

    Scott McGuire
    Fetch Softworks

    Posted 9 years ago #

Reply

  • Or nickname, if you prefer.
  • This will be kept confidential.
  • This is to ensure that you’re a person, not a spambot.