Your best friend for file transfer.

Fetch application logoFetch

Bogus error message 'connection reset' (7 posts)

  • Started 7 years ago by DerekTearne
  • Latest reply 7 years ago from Jim Matthews
  • DerekTearne Member

    Since upgrading to 5.2 uploading files to some sites gives an error dialogue:

    "Fetch could not put <filename> because the connection was reset by the server. Contact the server administrator to verify that you have the correct hostname. Server responded: "Ok to send data". "

    I have been succesfully uploading files to these sites for years using fetch without any problem, so I know the hostname is correct.

    In fact, even though the message says the file could not be uploaded the files are being uploaded. It is, however, somewhat distracting to have the dialogue pop up every time a file is uploaded.

    Is there any setting I can change to resolve this?

    --- Derek

    Posted 7 years ago #

  • Scott McGuire Administrator

    Hi Derek,

    Sorry you're having problems. We'd like more information to help figure out what the cause might be.

    The next time you get the error, please choose Fetch Transcript from the Window menu, copy the entire contents of the transcript window, and paste them into a reply to this message.

    We'll take a look and try to figure out what's going on.

    Thanks,

    Scott McGuire
    Fetch Softworks

    Posted 7 years ago #

  • DerekTearne Member

    Here is transcript - I've snipped most of the files in the directory listing for brevity.

    send_cmd():con_conn->Putline() returns 2,-50
    Update check started at 18/01/2007 23:29
    Update check skipped at 18/01/2007 23:30 (next check after 19/01/2007 15:05)
    Connecting to 203.167.250.125 port 21 (Mac OS X firewall is on) (19/1/07 12:01:34)
    Connected to 203.167.250.125 port 21 (19/1/07 12:01:35)
    220 Welcome to the FTP service.
    ADAT
    530 Please login with USER and PASS.
    AUTH This command is checking whether this server supports Kerberos or GSS security, see RFC 2228
    530 Please login with USER and PASS.
    USER ########
    331 Please specify the password.
    PASS
    230 Login successful.
    SYST
    215 UNIX Type: L8
    PWD
    257 "/"
    MACB ENABLE
    500 Unknown command.
    PWD
    257 "/"
    TYPE A
    200 Switching to ASCII mode.
    PASV
    227 Entering Passive Mode (203,167,250,125,240,218)
    Making data connection to 203.167.250.125 port 61658
    LIST -al
    150 Here comes the directory listing.
    drwxr-x--x 62 1542 1542 4096 Jan 17 11:37 .
    drwxr-x--x 3 1542 1542 4096 Mar 23 2006 ..
    -rw-r--r-- 1 1542 1542 15364 May 27 2005 .DS_Store
    -rw-r--r-- 1 1542 1542 93 Mar 22 2006 .htaccess
    -rw-r--r-- 1 1542 1542 1997 Jan 20 2004 404.html
    -rw-r--r-- 1 1542 1542 2662 May 19 2005 404style.css
    drwxr-xr-x 6 1542 1542 4096 Sep 27 12:41 Annual2006
    drwxr-xr-x 2 1542 1542 4096 Dec 09 2003 Annual99_summary
    ... snip ...
    drwxr-xr-x 3 1542 1542 4096 Dec 12 2003 web-trends
    226 Directory send OK.
    TYPE I
    200 Switching to Binary mode.
    PASV
    227 Entering Passive Mode (203,167,250,125,200,113)
    Making data connection to 203.167.250.125 port 51313
    STOR testimage.jpg
    150 Ok to send data.
    Unsuccessful transfer of testimage.jpg (78,191/78,191 bytes, 19,547 bytes/sec, 0:04 elapsed) stopped at 19/1/07 12:01:59 (error: 1,54)
    ftp_store_close: 1,54 (state == RPUT_CLOSING)
    ABOR
    226 File receive OK.
    225 No transfer to ABOR.

    Posted 7 years ago #

  • Scott McGuire Administrator

    Hi,

    Thanks for the transcript.

    Does the transcript say in it anywhere what kind of server you are connecting to? (I don't see that information listed in this transcript, and I want to double-check that it just didn't get edited out.)

    And just to confirm, you're not using Kerberos (GSSAPI or KClient) to connect, is that correct?

    Thanks,

    Scott McGuire
    Fetch Softworks

    Posted 7 years ago #

  • DerekTearne Member

    Thanks Scott.

    That's all the information that was in the transcript - I only deleted a load of files. There was no welcome message saying server type.

    However, the server type is as follows:
    Linux linux10 2.4.27-3-686 #1 Tue Dec 5 21:03:54 UTC 2006 i686

    I'm not using Kerberos.

    --- Derek

    Posted 7 years ago #

  • Scott McGuire Administrator

    Hi Derek,

    Thanks for the additional information. We're looking into the problem.

    In the meantime, if you revert to Fetch 5.1.1, the errors should go away. If they don't, please let us know. You can download Fetch 5.1.1 from http://getfetch.com/Fetch_5.1.1.dmg if necessary.

    Thanks,

    Scott McGuire
    Fetch Softworks

    Posted 7 years ago #

  • Jim Matthews Administrator

    Derek:

    We could use some more information to figure out what is going wrong. Could you follow these directions?

    1) While in Fetch, hold down Command, Option, Shift and Control and type the letter "d". A "Debug" menu should appear in the menu bar to the left of the Help menu.

    2) Choose Debug > Logging > CFReadWriteStream log and Debug > Logging > CStreamCF log to turn on logging for those two parts of Fetch.

    3) Upload a file.

    4) Email the contents of the Fetch Transcript window and the /var/log/system.log file to bugs at fetchsoftworks dot com. To find /var/log/system.log, choose Go to Folder... from the Go menu in the Finder, then enter:

    /var/log

    You should see a bunch of files with names that begin with "system.log"; I'd like to see the one named just "system.log".

    Thanks for your help,

    Jim Matthews
    Fetch Softworks

    Posted 7 years ago #

Reply

  • Or nickname, if you prefer.
  • This will be kept confidential.
  • This is to ensure that you’re a person, not a spambot.