Your best friend for file transfer.

Fetch application logoFetch

Can't open Fetch: not supported on this architecture. (8 posts)

  • Started 6 years ago by Courmad
  • Latest reply 6 years ago from Scott McGuire
  • Courmad Member

    I've been using Fetch for years. All of a sudden today I got this message:

    "You cannot open the application Fetch because it is not supported on this architecture."

    I'm stuck. I have no idea what this means or what to do about it. I have rebooted and I have trashed my preferences for Fetch and I'm still getting the message.

    Can one one here help me? If so, please bear in mind I am not very tech savvy and will need the simplified version of your answer.

    Thank you so much.

    Posted 6 years ago #

  • Scott McGuire Administrator

    Hi,

    We'd like some more information to help diagnose your problem.

    Could you tell us what kind of Macintosh you have?

    And what version of the Mac OS you are using? (If you're not sure, go to the blue Apple menu, choose "About this Mac" and a window that tells you your version of Mac OS should appear.)

    Thanks,

    Scott McGuire
    Fetch Softworks

    [This message has been edited by ScottMcGuire (edited 04-07-2008).]

    Posted 6 years ago #

  • Courmad Member

    Originally posted by ScottMcGuire:

    Hi,

    We'd like some more information to help diagnose your problem.

    Could you tell us what kind of Macintosh you have?

    And what version of the Mac OS you are using? (If you're not sure, go to the blue Apple menu, choose "About this Mac" and a window that tells you your version of Mac OS should appear.)

    Thanks,

    Scott McGuire
    Fetch Softworks

    [This message has been edited by ScottMcGuire (edited 04-07-2008).]

    Scott:

    I'm on a Power Book G4, using Leopard 10.5.2

    Thanks,

    Courmad

    Posted 6 years ago #

  • Scott McGuire Administrator

    Hi Courmad,

    Thanks for the info.

    You haven't switched to a new Mac recently, have you?

    Could you please tell us which version of Fetch you are using? You can find out by:

    * Open the Applications folder.
    * Find the Fetch icon.
    * Click once to select the Fetch icon.
    * Go to the File menu, and choose Get Info.
    * In the "General" section of the info window, you should see the version of Fetch listed.

    Thanks,

    Scott McGuire
    Fetch Softworks

    Posted 6 years ago #

  • Courmad Member

    Originally posted by ScottMcGuire:

    Hi Courmad,

    Thanks for the info.

    You haven't switched to a new Mac recently, have you?

    Could you please tell us which version of Fetch you are using? You can find out by:

    * Open the Applications folder.
    * Find the Fetch icon.
    * Click once to select the Fetch icon.
    * Go to the File menu, and choose Get Info.
    * In the "General" section of the info window, you should see the version of Fetch listed.

    Thanks,

    Scott McGuire
    Fetch Softworks

    Hi Scott,

    This is intereting. The Fetch version in my applications folder is 5.2. However I noticed I had kept Fetch_5.3.dmg after I installed it. I remembered that I had recently been notified of the upgrade and installed 5.3 in my applications folder. It is since I did that that I've had the problem.

    I tried to reinstall 5.3 again just now and only 5.2 shows up in my Applications folder.

    My Mac is not new. It's about 2.5 years old.

    Thanks,
    Courmad

    Posted 6 years ago #

  • Scott McGuire Administrator

    Hi Courmad,

    My guess is something went wrong when you tried to install Fetch 5.3, and you should try doing a really clean install.

    Here's what I recommend (doing this will not erase your preferences or shortcuts):

    * Put the Fetch_5.3.dmg you have currently into the Trash.
    * Put the copy of Fetch in your Applications folder in the Trash.
    * Download a new copy of Fetch 5.3 from our website at http://fetchsoftworks.com .
    * Install the newly downloaded copy of Fetch 5.3 into your Applications folder.
    * Try to run Fetch.

    Let me know if that works or not.

    Thanks,

    Scott McGuire
    Fetch Softworks

    Posted 6 years ago #

  • Courmad Member

    Originally posted by ScottMcGuire:

    Hi Courmad,

    My guess is something went wrong when you tried to install Fetch 5.3, and you should try doing a really clean install.

    Here's what I recommend (doing this will not erase your preferences or shortcuts):

    * Put the Fetch_5.3.dmg you have currently into the Trash.
    * Put the copy of Fetch in your Applications folder in the Trash.
    * Download a new copy of Fetch 5.3 from our website at http://fetchsoftworks.com .
    * Install the newly downloaded copy of Fetch 5.3 into your Applications folder.
    * Try to run Fetch.

    Let me know if that works or not.

    Thanks,

    Scott McGuire
    Fetch Softworks

    Thanks, Scott, that seems to have done the trick, with one exception. When I try to empty the trash, I get this message: "The operation can not be completed because the item fetch_5.3.dmg is in use.

    I don't think it's in use as I used it and I'm finished. Any deas what i can do about this?

    Thanks,

    Courmad

    Posted 6 years ago #

  • Scott McGuire Administrator

    Hi Courmad,

    Glad to hear that fixed the problems running Fetch.

    I believe if you restart the Mac, then you will be able to empty the trash. (Restarting usually closes any "open" files.) If that doesn't do the trick, let me know and I will try to suggest alternatives.

    Thanks,

    Scott McGuire
    Fetch Softworks

    Posted 6 years ago #

Reply

  • Or nickname, if you prefer.
  • This will be kept confidential.
  • This is to ensure that you’re a person, not a spambot.