Your best friend for file transfer.

Fetch application logoFetch

Fetch 3 and Router in home?? (3 posts)

This is an archived topic. The information in it is likely to be out-of-date and no longer applicable to current versions of Fetch.
  • Started 11 years ago by D. Kirkpatrick
  • Latest reply 11 years ago from D. Kirkpatrick
  • D. Kirkpatrick Member

    Fetch 3.03
    Mac G3 Beige, OS 9.2.1

    After installing a DSL D-Link Router and upgrading to DSL, I cannot make Fetch work with my web server. This particular server requires a login with a port number. In Fetch, that is accomplished by entering the domain name, space, then port number. Since going to this router, any web site I need to access using a port designation returns an "invalid port number" error.

    I can still use Fetch over this ethernet-to-router line to access AOL FTP space (while dialed in to AOL) and to a Unix server that has no port requirements. Only those (3 sites) that I need to access with a port designation are failing.

    Curiously, I can use Anarchie 3.7 and that accesses it fine.

    The web host suggests that its the router and I need to change some settings, or that it may be the program.

    The web server I am trying to upload to is a Windows 2000 server.

    Oddly, WhatRoute has also ceased to be able to run a trace (Ping works as does Whois) so the router may be suspect, but I am at a loss as to what to do next.

    When I chance the settings in Fetch to use the router as the firewall, which is what it appears to be doing, NOTHING happens. When these settings are removed and unchecked, I get the port error.

    Odd.

    Any help or pointers will be appreciated.

    If I can get this to work I will seek out a later version of Fetch. If I cannot, I have to use Anarchie.

    DMK

    Posted 11 years ago #

  • Jim Matthews Administrator

    Have you tried changing the "Use passive mode transfers (PASV)" box in the Firewall section of Preferences?

    If that doesn't help could you post the contents of the Fetch Transcript window after you see the error message? Choose "Fetch Transcript" from the Window menu to reveal it.

    Thanks,

    Jim Matthews
    Fetch Softworks

    Posted 11 years ago #

  • D. Kirkpatrick Member

    Originally posted by JimMatthews:

    Have you tried changing the "Use passive mode transfers (PASV)" box in the Firewall section of Preferences?

    If that doesn't help could you post the contents of the Fetch Transcript window after you see the error message? Choose "Fetch Transcript" from the Window menu to reveal it.

    Thanks,

    Jim Matthews
    Fetch Softworks

    --------

    Jim Thanks.

    Setting to PASV was the answer. The Web hots insisted that they did nothing on their end but I have not changed the Prefs in Fetch for years so they had to be fibbing to me.

    FWIW< I cured the WhatRoute issue by swittching packet type. It appears that UDP is blocked at my router so I need to address that.

    Anarchie still cannot runa trace and there is no way to make adjustments in that as far as I can see.

    I use Fetch for 99% of everything anyway.

    My best to you and the good people at Fetch works.

    Posted 11 years ago #

Topic closed

This topic has been closed.