Your best friend for file transfer.

Fetch application logoFetch

IE 5 Cannot read your website! (6 posts)

  • Started 4 years ago by Pete Bonk
  • Latest reply 4 years ago from Scott McGuire
  • Pete Bonk Member

    I have Mac OS 9 and am still running IE 5. Your website download links for Fetch 4.03 are not readable in IE 5. Any way I can buy Fetch in some other way?

    Posted 4 years ago #

  • Scott McGuire Administrator

    Hi Pete,

    What you can do is download Fetch 4.0.3 for Mac OS 9 using this link:

    http://fetchsoftworks.com/fetch/download/Fetch_4.0.3.sit

    And then you can use Fetch 4.0.3's built-in purchase function to buy it (no web browser required). You can either click the "Purchase" button when you open Fetch 4, or use the "Purchase" menu item in the File menu.

    That should work for you, but if it doesn't, let us know and we'll suggest something else.

    Thanks,

    Scott McGuire
    Fetch Softworks

    Posted 4 years ago #

  • Pete Bonk Member

    Scott-

    I got Fetch 4.0.3 downloaed but the purchase method does not work. The card expiration dates only go to 2011. I do not have any cards that old!

    Pete Bonk

    Posted 4 years ago #

  • Scott McGuire Administrator

    Hi Pete,

    Whoops! Well, back when Fetch 4.0.3 was released, 2011 was a long way away... I don't know if we can do anything about that, but we'll take a look.

    My next suggestion is to try our alternate webstore at:

    http://fetchsoftworks.com/fetch/buy/kagi

    It may work better with old web browsers.

    While the store will say you're buying Fetch 5, the serial number you receive will work with Fetch 4.

    Be sure to remove the CD from your order if you don't want a CD (it's optional).

    Let me know if that doesn't work for you either.

    Thanks,

    Scott McGuire
    Fetch Softworks

    Posted 4 years ago #

  • Pete Bonk Member

    Scott-

    The site was buggy and seemed to have trouble processing my credit card. I'm not sure it it went through. Will you check.? If not I will purchase via standard site and serialize my version of 4.0.3 with the serial number if it works.

    Pete Bonk

    Posted 4 years ago #

  • Scott McGuire Administrator

    Hi Pete,

    Sorry to hear that site didn't work well with a Mac OS 9-era browser either.

    I have checked and no, your purchase did not go through - you will not be charged for that attempt.

    I have emailed you a link to another store that you might have more success with than our standard store; you can give it a try and see if it works better in IE5 on Mac OS 9.

    Thanks,

    Scott McGuire
    Fetch Softworks

    Posted 4 years ago #

Reply

  • Or nickname, if you prefer.
  • This will be kept confidential.
  • This is to ensure that you’re a person, not a spambot.