Your best friend for file transfer.

Fetch application logoFetch

Program will not open (2 posts)

  • Started 2 years ago by artist27010
  • Latest reply 2 years ago from Jim Matthews
  • artist27010 Member

    True to form, I tried to fix something was not broken and. . .
    The new upgrade will not open at all on my Macintosh
    OS X
    Version 10.4.11
    Help!

    Posted 2 years ago #

  • Jim Matthews Administrator

    Hi,

    Fetch 5.7 requires OS X 10.5 on an Intel Mac. You should try Fetch 5.6, available at http://fetchsoftworks.com/fetch/download .

    Thanks,

    Jim Matthews
    Fetch Softworks

    Posted 2 years ago #

Reply

  • Or nickname, if you prefer.
  • This will be kept confidential.
  • This is to ensure that you’re a person, not a spambot.