Your best friend for file transfer.

Fetch application logoFetch

Purchase Fetch or Purchase upgrade (3 posts)

  • Started 1 year ago by Soopermark
  • Latest reply 1 year ago from Soopermark
  • Soopermark Member

    Hi. I am using Fetch v4.0.3 on Mac 10.6.8. I like Fetch and have always used Fetch. Now my web host has told me that I need "to change your FTP program to use FTPS (FTP over TLS - Explicit) Encryption" this is for security compliance.

    Now I'd like to have the most current version of Fetch. I should purchase the upgrade, not a new version, right? Will v5.7 accommodate the FTPS requirement?

    Thanks!

    Posted 1 year ago #

  • Jim Matthews Administrator

    Yes, you should purchase the upgrade, which is $10 (a new license is $29). The latest version, Fetch 5.7, supports FTPS.

    Thanks,

    Jim Matthews
    Fetch Softworks

    Posted 1 year ago #

  • Soopermark Member

    Thanks Jim! I will purchase that later this afternoon.

    Posted 1 year ago #

Reply

  • Or nickname, if you prefer.
  • This will be kept confidential.
  • This is to ensure that you’re a person, not a spambot.