Your best friend for file transfer.

Fetch application logoFetch

Right OS X version but upgrade won't support (2 posts)

  • Started 3 years ago by amy
  • Latest reply 3 years ago from Jim Matthews
  • amy Member

    I just bought the 5.7 upgrade online for my mac. I hadn't deleted the trial icon before installing the new but put in the serial number from the upgrade I had just bought and it worked. But then I thought I should install the actual one I purchased and it asked if it should replace the old version with the newer version — I said yes. Now the newer version won't install and gives me the same message as jill, "You cannot open the application "Fetch" because it is not supported on this architecture". My issue is this: I have a Mac G5 running OS X 10.5.8 so why couldn't I use the Fetch 5.7? Do I have to use 5.6?

    Posted 3 years ago #

  • Jim Matthews Administrator

    Fetch 5.7 requires an Intel Mac, so it won't run on your G5. You can use Fetch 5.6, which you can download from http://fetchsoftworks.com/fetch/download .

    Thanks,

    Jim Matthews
    Fetch Softworks

    Posted 3 years ago #

Reply

  • Or nickname, if you prefer.
  • This will be kept confidential.
  • This is to ensure that you’re a person, not a spambot.