Your best friend for file transfer.

Fetch application logoFetch

Running Dog with progressive but unending file transfer! (11 posts)

This is an archived topic. The information in it is likely to be out-of-date and no longer applicable to current versions of Fetch.
  • Started 13 years ago by MickBCN
  • Latest reply 12 years ago from MickBCN
  • MickBCN Member

    This problem I have only on a certain server..... The server Tech support have examined their settings and say everything is correct?
    I have more or less the same problems trying to access with other FTP clients.
    FTP access on a PC works correctly!

    Using Fetch the connection is constantly trying to "Get the file list" until I stop it. It then displays the file list and then 'sometimes' I can download 1 out of maybe 20 attempts but only a file or 2 at a time.
    Assume that every possible FTP configuration option has been tried.. Macbinary, raw text, passive on/off etc... etc...

    Meanwhile I do not have problems accessing and 'getting' from other servers?

    Here is the transcript - My notes and actions are <<indicated in THIS STYLE>>:

    System Version = 0x904
    Connecting to 199.231.128.165 port 21 (11/9/01 1:08:47 PM)
    220 ntweb05 Microsoft FTP Service (Version 4.0).
    ADAT
    500 'ADAT Hi there, do you support security?': command not understood
    USER wpinyc
    331 Password required for wpinyc.
    PASS
    230 User wpinyc logged in.
    SYST
    215 Windows_NT version 4.0
    PWD
    257 "/wpinyc" is current directory.
    MACB ENABLE
    500 'MACB ENABLE': command not understood
    SITE DIRSTYLE
    200 MSDOS-like directory output is on
    SITE DIRSTYLE
    200 MSDOS-like directory output is off
    CWD htdocs
    250 CWD command successful.
    PWD
    257 "/wpinyc/htdocs" is current directory.
    PORT 172,26,0,3,30,106
    200 PORT command successful.
    LIST
    150 Opening ASCII mode data connection for /bin/ls.
    drwxrwxrwx 1 owner group 0 Jun 21 12:26 browsetest
    drwxrwxrwx 1 owner group 0 Jun 29 17:29 cam
    drwxrwxrwx 1 owner group 0 Jul 1 3:22 cam2
    drwxrwxrwx 1 owner group 0 Apr 5 10:42 cgi-bin
    drwxrwxrwx 1 owner group 0 Nov 7 23:06 Clientarea
    drwxrwxrwx 1 owner group 0 Jun 21 13:26 Clients
    drwxrwxrwx 1 owner group 0 Jul 4 10:55 ColorTest
    -rwxrwxrwx 1 owner group 1267 Jun 21 13:59 flashstage.html
    drwxrwxrwx 1 owner group 0 Jun 29 9:52 Georgia
    drwxrwxrwx 1 owner group 0 Jun 29 9:45 HTMLsite
    drwxrwxrwx 1 owner group 0 Jun 21 14:04 Images
    -rwxrwxrwx 1 owner group 2531 Nov 5 11:42 index.html
    -rwxrwxrwx 1 owner group 10808 Oct 31 4:19 indexOLDsite.html
    drwxrwxrwx 1 owner group 0 Jun 21 14:03 IndexPage images
    drwxrwxrwx 1 owner group 0 Aug 7 15:22 irsicaixa.org
    drwxrwxrwx 1 owner group 0 Jun 21 12:22 kim-test
    drwxrwxrwx 1 owner group 0 Jun 21 12:22 merck
    -rwxrwxrwx 1 owner group 551 Jun 21 13:59 name.inc
    drwxrwxrwx 1 owner group 0 Aug 22 12:27 NEW
    drwxrwxrwx 1 owner group 0 Jun 21 12:23 personal
    drwxrwxrwx 1 owner group 0 Jun 29 8:22 Scope
    drwxrwxrwx 1 owner group 0 Jun 29 8:11 sourcesqt
    drwxrwxrwx 1 owner group 0 Apr 5 10:42 stats
    drwxrwxrwx 1 owner group 0 Jun 21 12:23 Templates
    drwxrwxrwx 1 owner group 0 Aug 17 10:57 test2001
    drwxrwxrwx 1 owner group 0 Aug 8 11:12 transfer
    <<at this POINT THE FILE LIST IS DISPLAYED BUT THE DOG IS STILL RUNNING>>
    <<i click ON 'STOP'>>
    ABOR
    CStreamOT::Read() OTRcv() returned -3208
    226 Transfer complete.
    225 ABOR command successful.
    NOOP
    200 NOOP command successful.
    NOOP
    200 NOOP command successful.
    <<i select SOME FILES TO "GET" AND DRAG THEM TO MY HARD DRIVE>>
    QUIT
    221
    Connecting to 199.231.128.165 port 21 (11/9/01 1:14:34 PM)
    220 ntweb05 Microsoft FTP Service (Version 4.0).
    ADAT
    500 'ADAT Hi there, do you support security?': command not understood
    USER wpinyc
    331 Password required for wpinyc.
    PASS
    230 User wpinyc logged in.
    SYST
    215 Windows_NT version 4.0
    PWD
    257 "/wpinyc" is current directory.
    MACB ENABLE
    500 'MACB ENABLE': command not understood
    SITE DIRSTYLE
    200 MSDOS-like directory output is on
    SITE DIRSTYLE
    200 MSDOS-like directory output is off
    CWD htdocs
    250 CWD command successful.
    PWD
    257 "/wpinyc/htdocs" is current directory.
    SIZE flashstage.html
    213 1267
    MDTM flashstage.html
    500 'MDTM flashstage.html': command not understood
    PORT 172,26,0,3,238,71
    200 PORT command successful.
    RETR flashstage.html
    150 Opening ASCII mode data connection for flashstage.html(1267 bytes).
    226 Transfer complete.
    <<<even though THE TRANSCRIPT SAYS THE TRANSFER IS COMPLETE, I HAVE NOT GOT MY FILES? THE STATUS IS STILL "GETTING FILES" THE TRANSFER INDICATOR SHOWS A "FULL" CIRCLE AND THE TRANSFER SHOWS THE BYTES PER SECOND RATE AS DROPPING - BUT THIS IS AN INFINITE LOOP AND NEVER STOPS OR NEVER GETS TO "ZERO" >>>
    <<< THE ONLY OPTION I HAVE NOW IS TO "STOP">>>
    ABOR
    CStreamOT::Read() OTRcv() returned -3208
    225 ABOR command successful.
    PORT 172,26,0,3,141,225
    200 PORT command successful.
    LIST...................

    <<< THIS PROBLEM ONLY HAPPENS ON THIS PARTICULAR SERVER>>>
    <<< THEIR SERVER TECH SUPPORT SAYS IT IS AN ERROR ON MY FTP SIDE >>>
    <<< I HAVE TRIED EVERY COMBINATION OF SETTINGS TO NO AVAIL >>>

    ANY IDEAS TO HELP ME RECTIFY THIS ?

    Posted 13 years ago #

  • Jim Matthews Administrator

    This problem is mentioned in the FAQ list on the website:

    http://fetchsoftworks.com/Support/faq.html#trouble2 :

    2. The progress bar fills the entire circle, but the transfer never finishes.

    One possibility is that the server is running Windows NT 4 Service Pack 6; there is a known problem with the tcpip.sys file of that release and Mac clients. If that is the case, one workaround is to replace the tcpip.sys file on the server with the one from Service Pack 5.

    Jim Matthews
    Fetch Softworks

    Posted 13 years ago #

  • dwjngs Member

    This is the same problem I have (see 'Fetch Hangs...' posting); same description, same efort on my part to adjust settings, etc. Every conceivable combination -- very puzzling. I'm on a UNIX server, so the NT thing isn't the issue...

    Any other ideas?

    Don

    Posted 13 years ago #

  • jonau99 Member

    I too have posted something somewhere on here regarding a similar problem where a file transfer (uploading or downloading) would not completely finish the circle and the Fetch doggie just runs and runs and I'm running Rumpus 2.0.2 FTP Server on a Mac OS 9.1 and Mac OS 9.2.1 Blue and White G3 computer and also WebSTAR webserver's built-in FTP server so the NT solution is not going to work for me. :-)

    [This message has been edited by jonau99 (edited 11-30-2001).]

    Posted 13 years ago #

  • Jim Matthews Administrator

    dwjngs and jonau99: Do you see this all the time, or just occasionally? Can you transfer files to and from ftp.fetchsoftworks.com?

    Thanks,

    Jim Matthews
    Fetch Softworks

    Posted 13 years ago #

  • jonau99 Member

    Originally posted by JimMatthews:

    dwjngs and jonau99: Do you see this all the time, or just occasionally? Can you transfer files to and from ftp.fetchsoftworks.com?

    Thanks,

    Jim Matthews
    Fetch Softworks

    No, not all the time...ocassionally but enough to make a website updating Applescript fail.

    As for ftp.fetchsoftworks.com, yes I was able to download from that site without any problems.

    Posted 13 years ago #

  • jonau99 Member

    Originally posted by JimMatthews:

    dwjngs and jonau99: Do you see this all the time, or just occasionally? Can you transfer files to and from ftp.fetchsoftworks.com?

    Thanks,

    Jim Matthews
    Fetch Softworks

    No, not all the time...ocassionally but enough to make a website updating Applescript fail.

    As for ftp.fetchsoftworks.com, yes I was able to download from that site without any problems.

    Posted 13 years ago #

  • munk Member

    I'm having the same problem with an endless "Getting file list..." and
    CStreamOT::Read() OTRcv() returned -3208
    My specs: iBook to Airport base station (DHCP) to Hub to Linux server running WU-FTPd, all of which is behind a Linksys router. The problem occurs whether I try to connect to the canonical name (which I presume would go outside the router then back through its IP forwarding) and directly to the local IP address.

    I don't know enough to know if this is a problem of local IP addresses and the file listing going to the router rather than the client...

    Posted 13 years ago #

  • Jim Matthews Administrator

    munk: could you post the contents of the Fetch Transcript window?

    Jim Matthews
    Fetch Softworks

    Posted 13 years ago #

  • MickBCN Member

    Originally posted by MickBCN:

    This problem I have only on a certain server..... The server Tech support have examined their settings and say everything is correct?
    I have more or less the same problems trying to access with other FTP clients.
    FTP access on a PC works correctly!

    Using Fetch the connection is constantly trying to "Get the file list" until I stop it. It then displays the file list and then 'sometimes' I can download 1 out of maybe 20 attempts but only a file or 2 at a time.
    Assume that every possible FTP configuration option has been tried.. Macbinary, raw text, passive on/off etc... etc...

    Meanwhile I do not have problems accessing and 'getting' from other servers?

    Here is the transcript - My notes and actions are <<indicated in THIS STYLE>>:

    System Version = 0x904
    Connecting to 199.231.128.165 port 21 (11/9/01 1:08:47 PM)
    220 ntweb05 Microsoft FTP Service (Version 4.0).
    ADAT
    500 'ADAT Hi there, do you support security?': command not understood
    USER wpinyc
    331 Password required for wpinyc.
    PASS
    230 User wpinyc logged in.
    SYST
    215 Windows_NT version 4.0
    PWD
    257 "/wpinyc" is current directory.
    MACB ENABLE
    500 'MACB ENABLE': command not understood
    SITE DIRSTYLE
    200 MSDOS-like directory output is on
    SITE DIRSTYLE
    200 MSDOS-like directory output is off
    CWD htdocs
    250 CWD command successful.
    PWD
    257 "/wpinyc/htdocs" is current directory.
    PORT 172,26,0,3,30,106
    200 PORT command successful.
    LIST
    150 Opening ASCII mode data connection for /bin/ls.
    drwxrwxrwx 1 owner group 0 Jun 21 12:26 browsetest
    drwxrwxrwx 1 owner group 0 Jun 29 17:29 cam
    drwxrwxrwx 1 owner group 0 Jul 1 3:22 cam2
    drwxrwxrwx 1 owner group 0 Apr 5 10:42 cgi-bin
    drwxrwxrwx 1 owner group 0 Nov 7 23:06 Clientarea
    drwxrwxrwx 1 owner group 0 Jun 21 13:26 Clients
    drwxrwxrwx 1 owner group 0 Jul 4 10:55 ColorTest
    -rwxrwxrwx 1 owner group 1267 Jun 21 13:59 flashstage.html
    drwxrwxrwx 1 owner group 0 Jun 29 9:52 Georgia
    drwxrwxrwx 1 owner group 0 Jun 29 9:45 HTMLsite
    drwxrwxrwx 1 owner group 0 Jun 21 14:04 Images
    -rwxrwxrwx 1 owner group 2531 Nov 5 11:42 index.html
    -rwxrwxrwx 1 owner group 10808 Oct 31 4:19 indexOLDsite.html
    drwxrwxrwx 1 owner group 0 Jun 21 14:03 IndexPage images
    drwxrwxrwx 1 owner group 0 Aug 7 15:22 irsicaixa.org
    drwxrwxrwx 1 owner group 0 Jun 21 12:22 kim-test
    drwxrwxrwx 1 owner group 0 Jun 21 12:22 merck
    -rwxrwxrwx 1 owner group 551 Jun 21 13:59 name.inc
    drwxrwxrwx 1 owner group 0 Aug 22 12:27 NEW
    drwxrwxrwx 1 owner group 0 Jun 21 12:23 personal
    drwxrwxrwx 1 owner group 0 Jun 29 8:22 Scope
    drwxrwxrwx 1 owner group 0 Jun 29 8:11 sourcesqt
    drwxrwxrwx 1 owner group 0 Apr 5 10:42 stats
    drwxrwxrwx 1 owner group 0 Jun 21 12:23 Templates
    drwxrwxrwx 1 owner group 0 Aug 17 10:57 test2001
    drwxrwxrwx 1 owner group 0 Aug 8 11:12 transfer
    <<at this POINT THE FILE LIST IS DISPLAYED BUT THE DOG IS STILL RUNNING>>
    <<i click ON 'STOP'>>
    ABOR
    CStreamOT::Read() OTRcv() returned -3208
    226 Transfer complete.
    225 ABOR command successful.
    NOOP
    200 NOOP command successful.
    NOOP
    200 NOOP command successful.
    <<i select SOME FILES TO "GET" AND DRAG THEM TO MY HARD DRIVE>>
    QUIT
    221
    Connecting to 199.231.128.165 port 21 (11/9/01 1:14:34 PM)
    220 ntweb05 Microsoft FTP Service (Version 4.0).
    ADAT
    500 'ADAT Hi there, do you support security?': command not understood
    USER wpinyc
    331 Password required for wpinyc.
    PASS
    230 User wpinyc logged in.
    SYST
    215 Windows_NT version 4.0
    PWD
    257 "/wpinyc" is current directory.
    MACB ENABLE
    500 'MACB ENABLE': command not understood
    SITE DIRSTYLE
    200 MSDOS-like directory output is on
    SITE DIRSTYLE
    200 MSDOS-like directory output is off
    CWD htdocs
    250 CWD command successful.
    PWD
    257 "/wpinyc/htdocs" is current directory.
    SIZE flashstage.html
    213 1267
    MDTM flashstage.html
    500 'MDTM flashstage.html': command not understood
    PORT 172,26,0,3,238,71
    200 PORT command successful.
    RETR flashstage.html
    150 Opening ASCII mode data connection for flashstage.html(1267 bytes).
    226 Transfer complete.
    <<<even though THE TRANSCRIPT SAYS THE TRANSFER IS COMPLETE, I HAVE NOT GOT MY FILES? THE STATUS IS STILL "GETTING FILES" THE TRANSFER INDICATOR SHOWS A "FULL" CIRCLE AND THE TRANSFER SHOWS THE BYTES PER SECOND RATE AS DROPPING - BUT THIS IS AN INFINITE LOOP AND NEVER STOPS OR NEVER GETS TO "ZERO" >>>
    <<< THE ONLY OPTION I HAVE NOW IS TO "STOP">>>
    ABOR
    CStreamOT::Read() OTRcv() returned -3208
    225 ABOR command successful.
    PORT 172,26,0,3,141,225
    200 PORT command successful.
    LIST...................

    <<< THIS PROBLEM ONLY HAPPENS ON THIS PARTICULAR SERVER>>>
    <<< THEIR SERVER TECH SUPPORT SAYS IT IS AN ERROR ON MY FTP SIDE >>>
    <<< I HAVE TRIED EVERY COMBINATION OF SETTINGS TO NO AVAIL >>>

    ANY IDEAS TO HELP ME RECTIFY THIS ?

    Posted 12 years ago #

  • MickBCN Member

    Jim
    Thanks for your help... The problem was definitely something to do with "Service Pack" compatibility. I can't pinpoint the exact solution for you, as my ISP's tech support system was naff and each time I communicated with them they could not call up a history of my problem, so I had to start from scratch each time! Smart lads!
    However, I can give you the following information for your records...
    1. FTP tests to a NT server with "Service Pack 5" worked perfectly for me. But somehow it caused other problems for the ISP on that server - so they would not allow me to use it.
    2. The final solution was to move my sites to a windows 2000 server where everything seems to function normally apart from FTP download speed which is slower.

    Posted 12 years ago #

Topic closed

This topic has been closed.