Your best friend for file transfer.

Fetch application logoFetch

Suddenly getting error after years of use... (4 posts)

This is an archived topic. The information in it is likely to be out-of-date and no longer applicable to current versions of Fetch.
  • Started 12 years ago by dnhatch
  • Latest reply 11 years ago from suziew96
  • dnhatch Member

    I've been using Fetch on a regular basis for years now, and it's worked perfectly all that time. Suddenly however, as of yesterday, I began experiencing a problem. After I connect to an FTP site, the Fetch status changes to "Getting file list...". The status remains there for several minutes, until I finally get a dialog box which says, "Server response: Can't build data connection: Operation already in progress".

    What could have happened? I've tried several things including deleting the Fetch preferences, reinstalling Fetch, and reinstalling the System Folder, but I'm still getting the error. Does anyone have any ideas? I'm assuming something has become corrupted, but I don't know what it could be.

    Here's the transcript:
    ----------------------------------------------
    Connecting to ftp.biostat.wisc.edu port 21 (8/23/02 12:35:07 PM)
    220 sadr FTP server (Version wu-2.6.2(1) Fri Nov 30 15:35:02 CST 2001) ready.
    USER hatch
    331 Password required for hatch.
    PASS
    230 User hatch logged in.
    SYST
    215 UNIX Type: L8
    PWD
    257 "/u/hatch" is current directory.
    PWD
    257 "/u/hatch" is current directory.
    PORT 128,104,104,37,6,172
    200 PORT command successful.
    LIST
    425 Can't build data connection: Operation already in progress.
    ftp_list: -30000
    ----------------------------------------------

    Dan Hatch
    University of Wisconsin Medical School

    Posted 12 years ago #

  • dnhatch Member

    After searching previous messages, I found this advice:

    "I'd recommend checking the "Use passive mode transfers (PASV)" in the Firewall section of Preferences."

    I tried that, and now the problem seems to be solved.

    I wonder why on Earth I suddenly started to have the problem in the first place after years of use though. Weird.

    Dan Hatch
    University of Wisconsin Medical School

    Posted 12 years ago #

  • ohtina Member

    wished that had worked for me. I'm still getting the "getting file list..." message, and no one has an answer for it.
    Glad for your success. :-)

    Posted 12 years ago #

  • suziew96 Member

    Exact same thing happened to me;I just wanted to thank you so much for your posting; I finally figured how to change the Preferences as specified (I was getting confused with AOL preferences or thinking there was some other system parameter I needed to set, not realizing it was an option in Fetch itself) and now miraculously Fetch is working again. THANK YOU! Peace. Jane Wang

    Posted 11 years ago #

Topic closed

This topic has been closed.