Your best friend for file transfer.

Fetch application logoFetch

Trouble with uploading cgi (3 posts)

This is an archived topic. The information in it is likely to be out-of-date and no longer applicable to current versions of Fetch.
  • Started 11 years ago by Clara
  • Latest reply 11 years ago from Clara
  • Clara Member

    Hi.

    I'm having trouble uploading cgi files. They seem to load correctly and I am able to set permissions but when I try to access them via my browser I encounter an "internal server error".

    These cgi file are part of a shopping cart. I have asked the author of the script for advice. He has downloaded the file in question, resaved it as a Unix file, and re-uploaded it, it suddenly started working. He has suggested that because I'm on a Mac, somehow the files are altered, possibly when I download them.

    Can you shed any light on this problem?

    Thanks

    Clara

    Posted 11 years ago #

  • Jim Matthews Administrator

    Make sure you upload the files in Text format -- that will make the line endings correct no matter what they are on your Mac.

    Thanks,

    Jim Matthews
    Fetch Softworks

    Posted 11 years ago #

  • Clara Member

    Thanks for the reply. I have been uploading in text format.

    I have discovered, by reading through other threads in this board, that I need to download the files in binary format and upload in text format.

    I don't know why but this seems to have dome the trick.

    Posted 11 years ago #

Topic closed

This topic has been closed.