Your best friend for file transfer.

Fetch application logoFetch

Uploaded my site, but it says 403 Forbidden (27 posts)

  • Started 4 years ago by Danosaur
  • Latest reply 3 years ago from Scott McGuire
  • Danosaur Member

    After uploading my site, when I try to view I get this message:

    Forbidden

    You don't have permission to access / on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    Apache/1.3.33 Server at www.venezuela-adventures.com Port 80

    I'm a newbie, please advise...

    Edited 4 years ago #

  • Scott McGuire Administrator

    Hi,

    Which program are you using to create your website?

    Thanks,

    Scott McGuire
    Fetch Softworks

    Edited 4 years ago #

  • Danosaur Member

    Adobe CS3 (Dreamweaver)

    Posted 4 years ago #

  • Scott McGuire Administrator

    Hi,

    Thanks for the information.

    There are two likely causes for this sort of problem.

    First, on many servers, the files that make up your website must go in a specially named folder, for example, one named "public_html", "htdocs", or "www" — the exact name of the folder will depend on your server. Usually you do not need to create this folder, it will already exist. You should check to make sure you uploaded your website files to the correct folder on the server. If you are unsure which folder you should put your website files in, you should contact the company or person that runs the server and ask which folder you should upload website files to.

    Second, it is possible you uploaded your website files inside a folder, when what you really needed to do was upload the contents of the folder, but not the folder itself.

    For example, let's say your website is in a folder called "My New Website", and inside that folder you have the pages and files that make up your website:

    So, on your Mac's hard drive, you might have:

    My New Website (folder)
      contact.html
      index.html
      Photos (folder)

    For your website to work correctly, you must be sure to upload the entire contents of the "My New Website" folder, but don't upload the "My New Website" folder itself.

    You should check for those two potential problems, and if you have made a mistake, try uploading again.

    If you still can't get it working, let us know and we can see if we can advise further.

    Thanks,

    Scott McGuire
    Fetch Softworks

    Edited 4 years ago #

  • Danosaur Member

    Thanks very much for your help, but I may have to through in the towel!

    I did as you suggested and now in addition I am getting a message stating that my images file is not in the site folder. I don't get it because I see it right there and the images are in it, any ideas?

    Thanks again.

    Daniel

    Posted 4 years ago #

  • Scott McGuire Administrator

    Hi Daniel,

    Which application is giving you an error about your images file not being in the site folder? Fetch, Dreamweaver, the web browser...?

    Thanks,

    Scott McGuire
    Fetch Softworks

    Posted 4 years ago #

  • Derek Scoggins Member

    ty this helped me for i am also trying to upload my website and am getting the same error message, im also a newbie, and tried uploading the whole folder instead of the contents themselves... I created my website using, powerpoint 2000 and saved it under "save as website" it saved two folders one as being the internet explorer link and the second all the files,slides, and pictures saved within the website. i am currently uploading them with Filezilla to my website is there anything else that you could suggest doing?

    Posted 4 years ago #

  • Scott McGuire Administrator

    Hi Derek,

    I'm sorry, but we are not familiar enough with Powerpoint 2000 or Filezilla to provide assistance or further suggestions. I would suggest trying to find a forum more geared towards those products and see if you can get help there.

    Thanks,

    Scott McGuire
    Fetch Softworks

    Edited 4 years ago #

  • kObz Member

    Hi,

    I'm having the same problem also, when I first used fetched to upload my website, it worked perfectly. After making minor tweaks to the website,I can no longer view my web page correctly. It says:

    "Forbidden You don't have permission to access / on this server.
    Additionally, a 404 Not Found error was encountered while trying to use an Error Document to handle the request."

    I need help please as this is very discouraging! If there is any method of fixing this other than what is already stated on the website please make them available. Thank You.

    I am also using Adobe Dreamweaver, the CS4 version though.

    Posted 4 years ago #

  • Jim Matthews Administrator

    Hello kObz,

    You probably need to sort this out with your web hosting provider, but I can take a look and see if I can make any suggestions. What is the URL of your website?

    Thanks,

    Jim Matthews
    Fetch Softworks

    Posted 4 years ago #

  • Derek Scoggins Member

    Hello, I found out what was wrong, in PowerPoint 2000 when you save it as a website, under the folder with the information and slides within it save the index.html as error.html, it was a simple fix as to renaming the error.html to index.html and it worked fine, website name is Dragonclayproductions.com, only problem i have now is that it will only work in internet explorer only because it was made in a Microsoft product..

    Posted 4 years ago #

  • kObz Member

    the URL is artlabmedia.com

    Posted 4 years ago #

  • Jim Matthews Administrator

    Thanks for posting the URL. I'm afraid there isn't anything I can do from this end. I would recommend contacting your hosting company for further assistance.

    Thanks,

    Jim Matthews
    Fetch Softworks

    Posted 4 years ago #

  • Will Member

    Hey Fetch,

    I've uploaded my website, and was fiddling with the owner/user permissions just before in my WWW folder, and now I too get the message:

    "Forbidden

    You don't have permission to access /home.html on this server.

    Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request."

    my website is called: http://www.enjoyyourselfclothing.com, which i can access, but not the rest of my links/pages.

    need help please, causing many problems.

    Will.

    Posted 4 years ago #

  • Scott McGuire Administrator

    Hi Will,

    I took a look at your website this morning and everything seems to be working now, so it looks like you figured out the problem.

    But please let us know if you have further questions.

    Thanks,

    Scott McGuire
    Fetch Softworks

    Posted 4 years ago #

  • Steve Member

    Hi,

    I uploaded a website today which was working absolutely fine, however because I was only updating I then had the problem that on Google it was still showing my old website. I read about using a .htaccess file to redirect the page, having done that, having no luck and deleting it again, the website no longer works at all, I just get a 403 Forbidden message. Any help ASAP would be much appreciated, I'm doing it for work, and I have a meeting with the boss tomorrow to show him the site... :-( HELP!!

    Thanks

    Steve

    Posted 4 years ago #

  • Scott McGuire Administrator

    Hi Steve,

    This sounds more like a question for your web hosting company (the people who run the server where your website is stored) than for us here at Fetch - they're in a better position to figure out how your .htaccess attempt interacted with their server and why deleting it might caused the site to stop showing up.

    So I'd recommend talking to them first, but if you're still stuck after doing that, let us know and we'll see if we can offer any suggestions.

    Thanks,

    Scott McGuire
    Fetch Softworks

    Posted 4 years ago #

  • Daniel L. Member

    make sure that the index file is "Index.htm" notice i did a capital i and no L in html. This worked for me.
    See page www.thejamesproject.ca

    Edited 4 years ago #

  • Rick Member

    I am using DreamweaverCS3. I am getting the Forbidden response when I try to access my site pensbyrob.com.
    I have tried everything I know to do.
    Thanks,
    Rick

    Posted 3 years ago #

  • Jim Matthews Administrator

    Hi Rick,

    Your site is coming up now.

    Jim Matthews
    Fetch Softworks

    Posted 3 years ago #

  • sascotchick Member

    Hi,

    I've been creating websites in WebPlus SE. Had no problems uploading new sites but when I've tried to update an existing one I get the 403 error. If you want to have a look it's www.ckidz.co.za Can you advise please as my boss is going mad!!!!!

    Thanks

    Posted 3 years ago #

  • Scott McGuire Administrator

    Hi sascotchick,

    We would recommend that you contact the people who make WebPlus SE for further assistance.

    Thanks,

    Scott McGuire
    Fetch Softworks

    Posted 3 years ago #

  • Lisa Member

    This was just happening to me last night when I was uploading my website and I looked all over message boards to find out how to get rid of it and I couldn't figure it out, so I called, its such a simple fix. MAKE SURE YOUR home.html page is lowercase. That fixed my problem!

    Posted 3 years ago #

  • Scott McGuire Administrator

    Hi Lisa,

    Thanks for the tip - the name of your index.html or home.html file not being in all lowercase is indeed a possible cause of this sort of problem.

    Best,

    Scott McGuire
    Fetch Softworks

    Posted 3 years ago #

  • Mondo Member

    I use visual studio and apparently some software edits the "web.config" file. call your hosting service and have them reset that file and BizWHAM your site is back on the saddle again.

    Posted 3 years ago #

  • Gabby Member

    Hi,

    I have created my website on Dreamweaver and it looks fine on the Live View, all links look great etc. However I have uploaded the site onto my ftp and the links have changed background colour on the live version. Only some of them have an error but the rest look fine. I have validated both the html and css, hence the ok looking site on Dreamweaver.

    I am also having issues with the error sign. This is the first time I've uploaded a site and maybe making mistakes.

    Here is the site for reference www.pentacle-solutions.com

    I am really confused, do you have any advice?

    Thanks

    Posted 3 years ago #

  • Scott McGuire Administrator

    Hi Gabby,

    Neither Fetch nor most other FTP clients make changes to your pages when you upload them, so this is most likely a problem with the webpage code somehow.

    We are not experts on Dreamweaver, so I would recommend asking your question on a discussion board related to Dreamweaver help and problems - I know Adobe has support forums, and there may be others.

    Thanks,

    Scott McGuire
    Fetch Softworks

    Posted 3 years ago #

Topic closed

This topic has been closed.