Your best friend for file transfer.

Fetch application logoFetch

Uploading iWeb files - shows unwanted page link (6 posts)

  • Started 6 years ago by lindalee
  • Latest reply 6 years ago from Scott McGuire
  • lindalee Member

    Hope this makes sense. Here goes:

    I deleted a page from my website, but after uploading my updated files, the navigation bar keeps showing the link to the page I deleted. I went back to double check I uploaded the correct files, and I did. Maybe it's getting late for me to be doing this. I don't know why it keeps doing this and I could really use your help.

    Thank you. -Linda

    Posted 6 years ago #

  • Scott McGuire Administrator

    Hi Linda,

    When you make a change to an iWeb site, you must re-publish your website to a folder and re-upload the entire website - that is, all of the files that make up the website. If you only upload some of the files, your website may not update properly.

    We have a help topic on using Fetch to upload websites created with iWeb (click the link to read it), which has other advice and covers some of the other things to watch out for. You may want to look it over if you haven't already.

    If you're still having trouble after trying this advice, please let us know - and tell us the URL of your website - and we'll see if we can help.

    Thanks,

    Scott McGuire
    Fetch Softworks

    Posted 6 years ago #

  • lindalee Member

    Thanks, Scott. I previously did re-publish to a folder and re-uploaded the entire website. Jusst to be sure, I did this procedure again. I have no "Photo" page on my website anymore and yet in the navigation area of this one page called "Events," there is a link called "Photo." Of course, when you click on that link you get a broken link message. I've refreshed and emptied the browser cache and I still have the same problem.

    I'm stumped. Thanks for your suggestion. Anymore suggestions?

    Linda

    Posted 6 years ago #

  • Scott McGuire Administrator

    Hi Linda,

    I'm sorry to hear that didn't fix the problem.

    I assume you do not see the bogus link on the "Events" page when you look at the page in iWeb?

    And what is the address (URL) of your website so we can take a look?

    Thanks,

    Scott McGuire
    Fetch Softworks

    Posted 6 years ago #

  • lindalee Member

    No, I do not see the bogus link on the page in iWeb.

    My URL address is seattlektc.org.

    Thank you so much for helping me with this.

    Posted 6 years ago #

  • Scott McGuire Administrator

    Hi Linda,

    I see the same problem you are seeing, and I see it on the Schedule and FAQ pages as well.

    Here's what I would try:

    * Create a new folder.
    * In iWeb, publish your updated webpage to that new, empty folder.
    * Connect to your server with Fetch.
    * Delete all the existing webpage files.
    * Upload the webpage that you just published to the new folder (remember to upload everything inside the folder, but not the folder itself).

    That should get make sure that none of the old files - either on your Macintosh or on the server - are being used again.

    Please let me know if this works or not, or if you have questions.

    Thanks,

    Scott McGuire
    Fetch Softworks

    Posted 6 years ago #

Reply

  • Or nickname, if you prefer.
  • This will be kept confidential.
  • This is to ensure that you’re a person, not a spambot.