Your best friend for file transfer.

Fetch application logoFetch

Uploading Site (8 posts)

  • Started 6 years ago by difred12
  • Latest reply 6 years ago from Scott McGuire
  • difred12 Member

    I have yet to beable to up-load anything to my website. Any help would be greatly appreciated. I keep getting a message that Fetch cannot create a folder because the FTP server sent an unexpected response.

    Transcript below:

    Fetch 5.2.1 (5C263) Intel running on Mac OS X 10.4.9 (8R2218) Intel English
    StuffIt Engine 0x820, StuffIt SDK Version 10.1.1b1
    Expires 10/08/2007 T
    Connecting to 01fafd7.netsolhost.com port 21 (Mac OS X firewall is off) (10/14/07 5:11:34 PM)
    Connected to 205.178.145.65 port 21 (10/14/07 5:11:34 PM)
    220 (vsFTPd 2.0.5)
    USER ntsl820607%01fafd7
    331 Please specify the password.
    PASS
    230 Login successful.
    SYST
    215 UNIX Type: L8
    PWD
    257 "/"
    MACB ENABLE
    500 Unknown command.
    PWD
    257 "/"
    Retrieved 2 items from file list cache, stored 10/14/2007 05:04 PM
    CWD A Scent From Heaven - Made in Maine
    550 Failed to change directory.
    MKD A Scent From Heaven - Made in Maine
    550 Create directory operation failed.
    ftp_mkdir: 2,-30000 (state == RPUT_MAKING_DIR)
    PWD
    257 "/"
    Retrieved 2 items from file list cache, stored 10/14/2007 05:04 PM

    Posted 6 years ago #

  • Scott McGuire Administrator

    Hi,

    My guess is the problem is the name of your folder; some servers do not accept folder or file names that contain spaces in them. The hyphen might also be a problem.

    I would try renaming your folder to not have spaces or the hypen and see if that helps.

    Depending on the software you are using to create your website, you may need to make these changes inside the website design program; renaming the folder may not be sufficient. Which program are you using to create your website?

    Thanks,

    Scott McGuire
    Fetch Softworks

    Posted 6 years ago #

  • difred12 Member

    I tried changing the name multiple times and still got the same response. I am using iWeb v.1.1.2 to build my site.
    Thanks

    Posted 6 years ago #

  • Scott McGuire Administrator

    Hi,

    Could you please do the following?

    * Quit Fetch, if it's open.
    * Open Fetch again.
    * Connect to your server.
    * Go to the View menu, and choose Refresh.
    * Then choose Fetch Transcript from the Window menu, copy the entire contents of the transcript window, and paste them into a reply to this message.

    Thanks,

    Scott McGuire
    Fetch Softworks

    Posted 6 years ago #

  • difred12 Member

    This is the transcript after just refreshing Fetch. I have yet to upload anything onto my server. There are however 2 folders that I am not able to delete. Thanks

    Fetch 5.2.1 (5C263) Intel running on Mac OS X 10.4.9 (8R2218) Intel English
    StuffIt Engine 0x820, StuffIt SDK Version 10.1.1b1
    Expires 10/08/2007 T
    Connecting to 01fafd7.netsolhost.com port 21 (Mac OS X firewall is off) (10/16/07 7:10:41 PM)
    Connected to 205.178.145.65 port 21 (10/16/07 7:10:41 PM)
    220 (vsFTPd 2.0.5)
    USER ntsl820607%01fafd7
    331 Please specify the password.
    PASS
    230 Login successful.
    SYST
    215 UNIX Type: L8
    PWD
    257 "/"
    MACB ENABLE
    500 Unknown command.
    PWD
    257 "/"
    TYPE A
    200 Switching to ASCII mode.
    PASV
    227 Entering Passive Mode (205,178,145,65,121,172)
    Making data connection to 205.178.145.65 port 31148
    LIST -al
    150 Here comes the directory listing.
    drwxr-xr-x 4 0 0 4096 Oct 09 13:16 .
    drwxr-xr-x 4 0 0 4096 Oct 09 13:16 ..
    drwxrwsr-x 2 0 1080694 4096 Oct 12 23:20 cgi-bin
    drwxrwsr-x 2 0 1080694 4096 Oct 12 23:32 htdocs
    226 Directory send OK.
    CWD /
    250 Directory successfully changed.
    PWD
    257 "/"
    PASV
    227 Entering Passive Mode (205,178,145,65,148,64)
    Making data connection to 205.178.145.65 port 37952
    LIST -al
    150 Here comes the directory listing.
    drwxr-xr-x 4 0 0 4096 Oct 09 13:16 .
    drwxr-xr-x 4 0 0 4096 Oct 09 13:16 ..
    drwxrwsr-x 2 0 1080694 4096 Oct 12 23:20 cgi-bin
    drwxrwsr-x 2 0 1080694 4096 Oct 12 23:32 htdocs
    226 Directory send OK.

    Posted 6 years ago #

  • Scott McGuire Administrator

    Hi,

    Thanks for the transcript.

    I believe the problem is that you need to put your website files into the server folder named "htdocs" - which you see in the Fetch file list.

    To do this, double-click on the "htdocs" folder in the Fetch file list, then try uploading your files.

    Also, since you are using iWeb to create your website, note that for your website to work correctly once you upload it, after you publish your website to a folder, you need to upload the contents of the folder - but not the folder itself - to your server.

    For example, let's assume your website is called "Family Trip", and when you use "Publish to a Folder," you tell iWeb to put its files in a folder called "My New Website."

    Once iWeb is done, in the Finder you will see:

    My New Website (folder)
      index.html
      Family Trip (folder)

    Inside the "Family Trip" folder will be folders and files corresponding to each page of your website.

    For your website to work correctly, you must be sure to upload both that index file, and the website folder - that is, upload the entire contents of the "My New Website" folder, but don't upload the "My New Website" folder itself.

    Let us know if this helps or not.

    Thanks,

    Scott McGuire
    Fetch Softworks

    Posted 6 years ago #

  • difred12 Member

    Worked perfectly. Thanks so much!!
    - Justin

    Posted 6 years ago #

  • Scott McGuire Administrator

    Hi Justin,

    You're welcome, we're glad to hear you're all set. Thanks for the followup.

    Best,

    Scott McGuire
    Fetch Softworks

    Posted 6 years ago #

Reply

  • Or nickname, if you prefer.
  • This will be kept confidential.
  • This is to ensure that you’re a person, not a spambot.