Your best friend for file transfer.

Fetch application logoFetch

Automated Download problem in Lion (2 posts)

  • Started 11 years ago by gryphon
  • Latest reply 11 years ago from gryphon
  • gryphon Member

    Quite some time ago I followed the steps on the site for scheduling automatic transfers with iCal.
    My automator workflow was saved as an app and then set a calendar alert to open/run the app file once a week.
    It all ran smoothly for a long time, but now I have a new Mac with Lion and I can't get the app to work.

    I tried recreating my workflow from scratch.
    I can actually run from the workflow and everything works fine. (Fetch connects to my server, gets the specified file, puts it in the chosen folder, renames the file, adds date stamp at end, and quits -- just as expected).

    But when I duplicate the workflow as an app and try to set scheduling in iCal to open the app file, it doesn't work.
    I checked activity monitor and I see my app show up in the list of process names, but it never downloads the file or quits the process. There is no indication that anything is wrong, it's just that nothing happens.

    I see that the kind in activity monitor shows Intel (64 bit) and I read some recommendations on this board to set Automator for 32 bit. I tried doing that, but when my app is fired at the scheduled time, I see it appear in activity monitor as 64 bit and nothing happens.

    Is there a bug that prevents an app from working with iCal on Lion?


    Posted 11 years ago #

  • gryphon Member

    UPDATE: looks like this is a never mind.
    I realized there was an OS update I was behind on so I ran it.
    That update has cleared the issue (or perhaps my mac was in a weird state and simply the restart of it fixed things).
    Anyway, now my scheduled downloads work as expected!

    Posted 11 years ago #


  • Or nickname, if you prefer.
  • This will be kept confidential.
  • This is to ensure that you’re a person, not a spambot.