Your best friend for file transfer.

Fetch application logoFetch

Automator wants access to control Fetch (3 posts)

  • Started 2 months ago by Traci
  • Latest reply 2 months ago from Traci
  • Traci Member

    I have had Automator accessing Fetch for many years now and it has worked flawlessly until the last several months.
    I am getting the error below. If someone is here to press okay, everything works fine. However, no one is here at 4 am to hit the okay button. I have tried to add the permissions Automator step but received other errors for that. Is there a way to automate the okay or give permission elsewhere I am not familiar with? I’ve checked preferences> security in mac preferences and have the script and fetch files set to full disk access and full accessibility. I haven’t updated fetch because according to your website, I’m under the impression we can’t automate after the 10.7.7 at the moment.

    Fetch version: 5.7.7
    Mac OS: Majave 10.14.3

    Posted 2 months ago #

  • Jim Matthews Administrator

    Hi Traci,

    It's strange that it asks you this question again and again; it should remember your answer. You might try this Terminal command:

    tccutil reset All

    After that you should be asked again to approve all sorts of things, but hopefully it will remember what you've approved.

    Thanks,

    Jim Matthews
    Fetch Softworks

    Posted 2 months ago #

  • Traci Member

    Thanks I'll try that.

    Posted 2 months ago #

Reply

  • Or nickname, if you prefer.
  • This will be kept confidential.
  • This is to ensure that you’re a person, not a spambot.