Your best friend for file transfer.

Fetch application logoFetch

Automator Workflow Suddenly Quit Working (17 posts)

  • Started 2 years ago by sharingsunshine
  • Latest reply 2 years ago from sharingsunshine
  • sharingsunshine Member

    Hi,

    I posted this question http://fetchsoftworks.com/fetch/messageboard/remove-files-via-automator - 5 years back and now it has suddenly quit working.

    When I run it I get the following message in the log
    http://gyazo.com/3436f82a62fb0ee066eb617a64b15d8d

    My workflow consists of the following
    Get Specified Fetch Items
    Filter Fetch Items - name contains .gz
    Filter Fetch Items - Item type is File

    I use this to backup the DB files from our server so please help me get this working again.

    I am on a Mac 10.9.5

    Thanks,

    Randal

    Posted 2 years ago #

  • Jim Matthews Administrator

    Hi,

    What output do you see from the Get Specified Fetch Items action?

    Thanks,

    Jim Matthews
    Fetch Softworks

    Posted 2 years ago #

  • sharingsunshine Member

    Hi Jim,

    I am not sure what you are asking. As far as I can see, the workflow terminates before any output. But if there is a log somewhere I need to look at please let me know.

    Thanks,

    Posted 2 years ago #

  • Jim Matthews Administrator

    Hi,

    Do you see a Results button at the bottom of each action in the workflow, next to the Options button? If you click on Results the action should expand to display its results. I'm curious to see what the results of the Get Specified Fetch Items action are, since the next action is complaining that it isn't getting any input.

    Thanks,

    Jim Matthews
    Fetch Softworks

    Posted 2 years ago #

  • sharingsunshine Member

    Hi Jim,

    I had to wait until the files it downloads were ready to be backed up before I could run it again. Unfortunately,

    it says "No Results Produced."

    Posted 2 years ago #

  • Jim Matthews Administrator

    What does the Get Specified Fetch Items action look like? Does it do any good to remove the items specified there, and then add them back again?

    Thanks,

    Jim Matthews
    Fetch Softworks

    Posted 2 years ago #

  • sharingsunshine Member

    the Get Specified Fetch Items is a list of database files that I download to my desktop. I would send you a screenshot but it has my IP number in the url. If you can give me a private address I can do that if it will help.

    Removing an item I am not clear what you mean by that. Is there an easy way to remove them and put them back because there are about 15 files listed.

    Posted 2 years ago #

  • Jim Matthews Administrator

    Hi,

    You can contact me privately using the form at http://fetchsoftworks.com/fetch/feedback

    Another idea would be to create a new workflow, add a Get Specified Fetch Items action, and add one of the database files. If you run that does the action have any output?

    Thanks,

    Jim Matthews
    Fetch Softworks

    Posted 2 years ago #

  • sharingsunshine Member

    Here is what the original workflow has in the Get Specified Fetch Items

    http://gyazo.com/5c75ef0bde56625374d93b0c60366240

    Trying it with a new workflow didn't change anything. I get the same error.

    Posted 2 years ago #

  • Jim Matthews Administrator

    Hi,

    Try checking the checkboxes next to the listed items; those checkboxes let you control whether a given item is passed to the next action in the workflow.

    Thanks,

    Jim Matthews
    Fetch Softworks

    Posted 2 years ago #

  • sharingsunshine Member

    I checked all the boxes and it ran longer but the results were nothing but a red x. I looked in the logs and it showed this

    http://gyazo.com/6eadcb352cd39e35f30acd416de9242a

    Posted 2 years ago #

  • Jim Matthews Administrator

    Hmm. Try checking just one of the boxes. And make sure Fetch is open.

    Thanks,

    Jim Matthews
    Fetch Softworks

    Posted 2 years ago #

  • sharingsunshine Member

    Automator crashes and Fetch opens up a window but never starts to download anything. Unless you have some suggestions I am going to consider this won't work and look elsewhere.

    Posted 2 years ago #

  • Jim Matthews Administrator

    I'm sorry that I don't have a sure-fire solution. Obviously something has changed. Other things you could try:

    * Restart your Mac
    * Delete all copies of Fetch and download a fresh copy of Fetch 5.7.5
    * Upgrade to OS X 10.10
    * Delete the ~/Library/Saved Application State/com.apple.Automator folder

    Thanks,

    Jim Matthews
    Fetch Softworks

    Posted 2 years ago #

  • sharingsunshine Member

    HI Jim,

    I don't fault you in any way. I have been with you for a long time and you have given great service and kept a great product going.

    I have just found Automator to be very lacking so I am going to look at a shell script to replace it if possible.

    Thanks for your help,

    Randal

    Posted 2 years ago #

  • Jim Matthews Administrator

    You might try recording an AppleScript. To do that:

    1) Open Script Editor
    2) Click the Record button
    3) Perform the file transfer steps manually in Fetch
    4) Click the Stop button in Script Editor

    You should then see a recorded script that will perform the same steps.

    Thanks,

    Jim Matthews
    Fetch Softworks

    Posted 2 years ago #

  • sharingsunshine Member

    That's a great idea. I just did it and it looks like that will work great. Thanks for reminding me about AppleScript.

    Posted 2 years ago #

Reply

  • Or nickname, if you prefer.
  • This will be kept confidential.
  • This is to ensure that you’re a person, not a spambot.