Your best friend for file transfer.

Fetch application logoFetch

cant open data file (2 posts)

This is an archived topic. The information in it is likely to be out-of-date and no longer applicable to current versions of Fetch.
  • Started 18 years ago by jluther
  • Latest reply 18 years ago from Jim Matthews
  • jluther Member


    We have been having problems getting to a few of our FTP site since switching to Panther and the current version of Fetch. (The connections are fine under System 9). I have tried various ways ... turning Passive off in Fetch, turning Passive off in X, turning both off, turning one on, etc. I have also tried many of the Misc preference settings.

    With Passive on I receive the following message ...
    Can't Open Data Connection

    With Passive off I receive this message ...
    The Server dropped the connection (it may be too busy)

    Here is the transcript with Passive On ...

    Fetch 4.0.3 System 0x1036 Serial FETCHFL001-483J-9G2R TR
    Connecting to port 21 (12/16/04 11:03:43 AM)
    220 maple Microsoft FTP Service (Version 5.0).
    USER spokesman
    331 Password required for spokesman.
    530 User spokesman cannot log in.
    Connecting to port 21 (12/16/04 11:04:01 AM)
    220 maple Microsoft FTP Service (Version 5.0).
    USER spokesman
    331 Password required for spokesman.
    230 User spokesman logged in.
    215 Windows_NT version 5.0
    257 "/" is current directory.
    500 'MACB ENABLE': command not understood
    200 MSDOS-like directory output is off
    257 "/" is current directory.
    227 Entering Passive Mode (192,168,34,8,15,154).
    425 Can't open data connection.
    ftp_list: -30000 (state == GETTING_LIST)

    Thanks, Jay

    Posted 18 years ago #

  • Jim Matthews Administrator

    If PASV mode does not work that usually indicates that there's a firewall on the server side that's blocking it. You can test that theory by trying to connect to (leave the User ID and Password fields blank); there's no firewall there, so PASV should work.

    You could ask the server administrators to enable passive mode. Failing that, you can uncheck PASV in Fetch. But if you do that you have to also make sure that there's no firewall on your side. So you should turn off the OS X firewall in the Sharing panel of System Preferences, and make sure there's no other firewall between your Mac and the Internet.


    Jim Matthews
    Fetch Softworks

    Posted 18 years ago #

Topic closed

This topic has been closed.