Your best friend for file transfer.

Fetch application logoFetch

Can't run 5.7 upgrade (2 posts)

  • Started 2 years ago by KPress
  • Latest reply 2 years ago from Jim Matthews
  • KPress Member

    My office manager sent the link to upgrade to Fetch 5.7; it downloaded but when I attempted to launch it I got the error message "not supported on this architecture." If my POS computer won't support the new version, how do I get the old version back?

    Posted 2 years ago #

  • Jim Matthews Administrator


    You can download older versions of Fetch at

    For example, you can download Fetch 5.6 (which runs on PowerPC Macs as long as they are running OS X 10.4.11 or later) at:


    Jim Matthews
    Fetch Softworks

    Posted 2 years ago #


  • Or nickname, if you prefer.
  • This will be kept confidential.
  • This is to ensure that you’re a person, not a spambot.