Your best friend for file transfer.

Fetch application logoFetch

Crash on quit, Virtual Memory, and AppleScript (3 posts)

This is an archived topic. The information in it is likely to be out-of-date and no longer applicable to current versions of Fetch.
  • Started 22 years ago by dac
  • Latest reply 22 years ago from dac
  • dac Member

    I've discovered an odd problem whose origin and resolution remains obscure to me: when Fetch is launched by an AppleScript with virtual memory turned off, it freezes my machine solid when you quit. Up to that point, Fetch and everything else apparently behave normally. I am not sure if this is a Fetch problem, an AppleScript problem, an OS problem, or some combination of the above. Any help or insight would be appreciated.

    Background: I recently took advantage of the current truly absurd memory prices to upgrade my Mac OS 9.1 B&W G3/450 to 1GB of RAM (from 702). I immediately concluded that one of the DIMM's I received was bad, because the machine would lock up solid when I attempted to reboot or shut down. The memory vendor sent me replacement chips right away. I was depressed to find that the symptom remained with the new chips.

    Over the course of the past week I've sorted out where the problem is focused. The salient facts are these. First, I noticed after a few days that it was always while the machine was trying to kill Fetch 4.0.1 that it froze. Second, I noticed something I'd never known before, that the Mac OS disables virtual memory if you have too much RAM (obviously a number somewhere between 702 MB and 1 GB.) This has since been confirmed by others. Third, I launch the applications I use most with an applescript in my Startup Items folder that launches, then hides, each application.

    Once I noticed that things were hanging up on Fetch, I experimented a bit and discovered that the machine would only freeze when you attempt to quit Fetch if it is launched by the applescript. If I launch Fetch by hand and quit, there's no problem. If I launch all of the applications the applescript launches in the same sequence, but by double-clicking in the Finder, there's no problem. The problem only occurs if Fetch is launched with the script, whether or not that script is run at startup, or after.

    Having discovered this, I then removed half the machine's memory and experimented some more. The symptom persisted, whether using my old pair of 256's or one of the new pairs. However, with only 512 MB I could enable virtual memory. With virtual memory enabled the problem disappears, no matter what combination of RAM I tried.

    The upshot is that I've now tried more or less all of the possible combinations, and the machine only locks up when you attempt to quit Fetch if *BOTH* (i) Fetch is launched with the applescript, and (ii) virtual memory is off.

    I tried three things to alleviate this crash: (i) increasing Fetch's memory allocation; (ii) increasing the applescript's memory; and (iii) increasing the memory available to the Finder with Reaper. None of these steps made any discernible difference.

    Any clues at all what's at issue here, or how to work around it? (There are two obvious possibilities: don't include Fetch in my applescript, or use another FTP client. I'm not thrilled about either choice, and besides, if this isn't specifically a problem with Fetch, I'm likely to meet this issue again, and I'd like to have some idea of what's going on.)


    [This message has been edited by dac (edited 11-03-2001).]

    Posted 22 years ago #

  • Jim Matthews Administrator

    Wow, that's some impressive sleuthing! I had seen this problem, but I had not made the connection to virtual memory. I can report, however, that the problem appears to be gone in Mac OS 9.2.1, so another workaround is to upgrade to that release. I believe that 9.2.1 is included with the OS X 10.1 package; I do not know if it is available for download.

    Thanks for the detective work!

    Jim Matthews
    Fetch Softworks

    Posted 22 years ago #

  • dac Member

    Thanks, Jim. I put so much effort into it because I needed to straighten out right away whether the RAM was at fault, or whether it was a software issue. The RAM vendor was kind enough to send me replacements on my say-so, so I needed to figure out whether to return them.

    FWIW, after posting this to mac-l, several others wrote in to say they'd also encountered freeze-on-quit problems with Fetch 4 with VM off; take the anecdote for what you will.

    I take it from your reply that this is new information, and hence aren't sure what's going on exactly. If you do figure out what's at fault, I'd be interested in knowing what you learn. (Making the switch to 9.2.1 is going to have to wait a while. I've got it on my OS X disk, but I don't have the time to mess with my OS 9.1 disk probably until Christmas. But it's useful to know.)

    David Craig

    Posted 22 years ago #

Topic closed

This topic has been closed.