Your best friend for file transfer.

Fetch application logoFetch

Error: "getting list of files" and than nothing happens (4 posts)

  • Started 18 years ago by Michael Tak
  • Latest reply 18 years ago from Scott McGuire
  • Michael Tak Member


    I just bought Fetch to keep my school-portfolio updated.
    When I try to connect to the server at school, there's a problem. I get the following message (because I use the duth language version I don't know the exact message in english, in dutch it's "Bestandslijst wordt opgehaald"), "Getting list of files". This message doesn't go away, and I don't get to my public folder. Finally I getthe message that there is a time out on the server. I tried today at school with the same log in and it works fine.

    I read some more or less similar topics and tried to connect to "". This works fine. Then I deleted my Fetch cache. This didn't help.

    Are you familiar with this problem? Does it have to do with the server at school?

    I copied the Fetch transcript, to make make things more clear for you.

    Fetch 5.0.4 (5A785) running on Mac OS X 10.3.9 (7W98) Dutch
    StuffIt Engine 0x702, StuffIt SDK Version StuffIt version 7.0.3
    Partial serial FETCH5X001-RDYV-RCH2 T
    Connecting to port 21 (11-11-2005 22:46:54)
    Connected to port 21 (11-11-2005 22:46:54)
    220---------- Welcome to Pure-FTPd ----------
    220-You are user number 3 of 50 allowed.
    220-Local time is now 22:47. Server port: 21.
    220-This is a private system - No anonymous login
    220-IPv6 connections are also welcome on this server.
    220 You will be disconnected after 15 minutes of inactivity.
    USER 0776619
    331 User 0776619 OK. Password required
    230-User 0776619 has group access to: 500
    230 OK. Current restricted directory is /
    215 UNIX Type: L8
    257 "/" is your current location
    500 Unknown command
    257 "/" is your current location
    CWD public_html
    250 OK. Current directory is /public_html
    257 "/public_html" is your current location
    TYPE A
    200 TYPE is now ASCII
    227 Entering Passive Mode (145,24,132,250,63,222)
    LIST -al
    Update check skipped at 11-11-2005 22:48 (next check after 12-11-2005 09:57)

    Thank you for your help!


    Posted 18 years ago #

  • Scott McGuire Administrator

    HI Michael,

    It sounds like this may be a firewall problem - the computers at your school may be behind a firewall. When you're at home, you're outside the school's firewall, so FTP connections have a problem going through. When you're at school, you and the server are both inside the firewall so there isn't a problem.

    Here are some things to try:

    * First, go to the Sharing panel of the Mac OS X System Preferences, and click on the Firewall tab. (Sorry, I don't know the Dutch translation for those items.) If your firewall is on, turn it off and see if the problem goes away. (I suspect it's a firewall at the school, but it doesn't hurt to check at home.)

    * In the Algemeen (General) pane of the Fetch Preferences, uncheck the "Gebruik passieve modus (PASV)" checkbox if it's checked, or check it if it's unchecked, and try a new connection to the server.

    Let us know if either of those solves the problem.


    Scott McGuire
    Fetch Softworks

    Posted 18 years ago #

  • Michael Tak Member

    Hello Scott,

    Well, I solved the problem. You were right... Right after I posted the message I went to the preference folder.
    I turned off the "Use Passive Modus (PASV)", checked again... and a BIG smile came to my face.

    Thank you for your help!

    Posted 18 years ago #

  • Scott McGuire Administrator

    Hi Michael,

    You're welcome, glad to hear it's working. Thanks for the followup.

    Scott McGuire
    Fetch Softworks

    Posted 18 years ago #


  • Or nickname, if you prefer.
  • This will be kept confidential.
  • This is to ensure that you’re a person, not a spambot.