Your best friend for file transfer.

Fetch application logoFetch

Fetch 5.0.4 CRASHED OS X 10.4.3 on G5 (2 posts)

  • Started 18 years ago by tempname
  • Latest reply 18 years ago from Scott McGuire
  • tempname Member

    Fetch 5.0.4 CRASHED OS X 10.4.3 on G5

    My dual-core 2.3GHz G5 is updated with all the updates to 10.4.3. I downloaded Fetch 5.0.4 from your Web site. When I tried to run it for the first time, it nearly hung my whole machine.

    I tried to Force Quit, but the Hour Glass just spun and spun.

    The rest of this may not be perfectly in chronological order. (Sorry.)

    Trying to Force Quit, or something, the G5 went into some weird mode. It was not shut down, nor did it seem to be asleep. When it came out of it -- I'm not sure how I got it out, maybe holding the power button -- the fans in the G5 started up at exceedingly high RPMs, then finally slowed down. The display came back to the previous screens.

    After a very long wait, at some point (I don't remember when), Force Quit, and other dialogs, came up.

    I Force Quit Fetch.

    I then made the mistake of RESTARTING Fetch, to see whether it would run okay or not. The Hour Glass spun and spun. I could not get it to Force Quit again. And so I tried to Quit applications.

    I Added Favorites to Safari to not lose my places. But then I made the mistake of doing a Save instead of an Add, and since the Finder was "hung", it hung Safari, and I lost the rest of my locations.

    iTunes was also running, and TextEdit.

    The Finder was unresponsive.

    I held the power button until it shut down.

    If I didn't know better, I'd say it acted like some weird VIRUS was involved. The machine is new; I've downloaded pretty much just standard software; I haven't even done email on it; so it's unlikely a virus came from elsewhere. (Hopefully.)

    HOWEVER, I have FOUR Macs, and only one of my other machines has crashed in a very long time -- the only other machine that has Fetch 5.0.4 on it! (That machine completely crashed while I was simply dragging files from a folder to a Flash RAM drive!)

    Whatever this is, I hope it gets resolved. It was all very weird.

    Thank you.

    ©2006 by Stephen DeVore. All rights reserved.

    Posted 18 years ago #

  • Scott McGuire Administrator


    We're sorry you're having troubles.

    First, we are certain there are no viruses in any of our Fetch distributions.

    We haven't had any other reports of problems like this, and Fetch does not make any changes to Mac OS X that could affect other programs, the Finder, or the operating system when Fetch is not running.

    Make sure that there are no old Fetch Preferences files that could be causing the problem. To do this:

    * Choose "Home" from the Go menu in the Finder
    * Open the Library folder
    * Open the Preferences folder
    * Move the files named "Fetch Prefs", "Fetch Cache", "Fetch Shortcuts", and "com.fetchsoftworks.Fetch.plist" to your desktop or another folder. (Don't trash them just yet.)

    Before running Fetch after you do this, throw out your current copy of Fetch 5.0.4, and download a fresh copy. Try running it again. If this fixes the problems, please send us the preferences files you moved to another folder so we can investigate.

    If this does not solve the problem, and you continue to experience problems with other applications even when Fetch is not running, that is probably an indication of problems with the operating system or possibly hardware problems. It would probably be a good idea to run Disk Utility and/or DiskWarrior to check your disk, run hardware diagnostics to check your machine, and consider reinstalling the OS.


    Scott McGuire
    Fetch Softworks

    Posted 18 years ago #


  • Or nickname, if you prefer.
  • This will be kept confidential.
  • This is to ensure that you’re a person, not a spambot.