Your best friend for file transfer.

Fetch application logoFetch

Fetch 5.3 will not load on Mac OS 10.5.5 (9 posts)

  • Started 11 years ago by dfnet
  • Latest reply 10 years ago from Scott McGuire
  • dfnet Member

    I just purchased an upgrade from Fetch v4.0 to v5.3, and installed v5.3 on my iMac Intel Core 2 Duo running OS X 10.5.5 (9F33). The previous Fetch v4.0 application resides on my other computer, a PowerPC G4 running OS 9.2.2.

    The "Fetch 5.3 Read Me" document says that "Fetch 5.3 will automatically read preferences and shortcuts from your previous version of Fetch when you first run it, and any documents saved by a previous version of Fetch will work with Fetch 5.3."

    Encouraged by the above text, and wishing to transfer all my shortcuts and log-ins from the G4 to the iMac, I copied the three Fetch 4.0 Preferences files (Fetch Cache, Fetch Prefs, Fetch Shortcuts) from the OS 9.2.2 System/Preferences folder to the OS X 10.5.5 Home/Library/Preferences folder before starting Fetch 5.3 for the first time on the iMac.

    Unfortunately, Fetch 5.3 would not load completely. Double-clicking on the file in Applications did place a Fetch icon on my Dock, but that icon merely bounced up and down for about a half-minute, and then stopped moving. The application did not load into my menu bar. Clicking on the Fetch icon in the Dock revealed a contextual menu with "Application Not Responding" grayed out, and offering me the option to Force Quit, which I did.

    Another attempt to load Fetch 5.3 brought the same result. Thinking that perhaps the three Fetch 4.0 preferences files had confused Fetch 5.3, I trashed all three prefs, emptied the trash, and restarted the iMac. Even with the old prefs gone, Fetch 5.3 would not load completely; the same half-minute bouncing in the Dock occurred, and then the icon just sat still on the Dock (with no blue ball under it that would indicate it was loaded), and its contextual menu contained the same grayed-out "Application Not Responding".

    I chose to "Force Quit" Fetch 5.3 again, and restarted the iMac a second time. Trying to load Fetch 5.3 still doesn't work.

    After reading some forum posts about related Fetch 5.3 difficulties in Leopard, I tried trashing the "" file, but that had no effect either. I also looked to see if there was a "Fetch.crash.log" file in my Home/Library/Logs/CrashReporter folder, but there was not.

    I have trashed Fetch 5.3 from Applications, and installed a fresh copy from the install disk image (fetch_5.3.dmg). I have checked Software Update for my OS 10.5.5, and everything is the most recent version.

    Following the instructions in another forum post, I have also repaired my Keychain Access (even though I had not seen any OS error messages), and restarted the Mac again. Still the same result: Fetch 5.3 will not load completely, its icon bounces in the Dock for a while and then stops, and there is no further progress of any kind -- just another "Application Not Responding" status.

    Needless to say, this experience has been somewhat exasperating! :-( Fetch 4.0 has been working fine on my G4 for a number of years (it still does), but I was looking forward to using the improved OSX version. Every other application on the iMac is working fine; Fetch is the only one that's misbehaving.

    Could you please tell me what I might be doing wrong, and how Fetch 5.3 can be made to load properly? Do you think I can still use my old Fetch 4.0 prefs from OS 9.2.2 to transfer my shortcuts?

    Thank you in advance for your assistance.

    Posted 11 years ago #

  • Scott McGuire Administrator


    We're sorry you're having trouble running Fetch 5.3 on Mac OS X 10.5.5; it should work.

    And yes, I think once we figure out what the problem with Fetch starting up is, you should be able to import your old shortcuts. But first we're going to focus on getting Fetch up and running.

    Thanks for the detailed list of troubleshooting steps that you have followed. We'd like you to gather some additional information that should tell us where Fetch is getting stuck.

    Could you please do the following?

    * Try opening Fetch. Once the Fetch icon has stopped bouncing proceed to the next step.
    * Open the Activity Monitor application (in the Utilities folder inside the Applications folder).
    * Go to the Window menu, and choose Activity Monitor.
    * Find Fetch in the list of processes - if you are having trouble finding it, type "Fetch" (without quotes) into the Filter field to show only Fetch in the list.
    * Select the Fetch entry, and click the Inspect button.
    * In the new window that appears, click the Sample button.
    * Click Save... to save the sample.
    * Send the saved file, along with a short description of your problem, to us at:

    bugs at

    We'll take a look and let you know what we find out.


    Scott McGuire
    Fetch Softworks

    Posted 11 years ago #

  • dfnet Member

    Thank you for your prompt reply, Scott! As you suggested, I have completed the Activity Monitor sample for Fetch, and sent along all the data to the "bugs" address. I hope that we can resolve the problem without too much difficulty.

    I have been reading a number of other forum threads, and must say that I'm impressed by your thorough and courteous replies to each post. As you probably know, there are many tech support people in the universe who are cryptic and condescending in their replies, but I detected none of that in yours.

    You come across as being very patient and helpful, even with the most "newbie" types of posts. What also impressed me is your willingness to guide users through detailed technical aspects of other applications, such as iWeb. That is going "above and beyond" -- and I'm certain that your clients appreciate it!

    Hopefully I will never need to ask you for Dreamweaver help, but if I were ever stymied by Adobe's tech support, then I'm guessing you might have some expertise with that as well. ;-)

    Posted 11 years ago #

  • Scott McGuire Administrator

    Hi Ian,

    You're welcome. We've received the info you sent to the bugs email address, and I've asked one of my colleagues to take a look at it; either he or I will follow up with you.

    Thanks very much for the kind words, I appreciate it!

    However, I'm afraid you might be on your own with Dreamweaver - I'm a GoLive user. :-) But I'm going to have to change to something else eventually, though...


    Scott McGuire
    Fetch Softworks

    Posted 11 years ago #

  • dfnet Member

    Hi, Scott!

    I'll readily admit that I'm no software technician, but when I looked through the Activity Monitor sample, I didn't see much useful data that could help diagnose the issue with Fetch not loading properly. Please tell me if your colleague would agree with that.

    However, it occurred to me that there might be another possibility:

    What if a packet had been corrupted during the download of the fetch_5.3.dmg file from It seemed plausible that if Eudora (on my G4) happened to be checking mail at the same time that the Fetch install file was being transferred to my iMac which is on the same network, then the crossing packets might have interfered with each other.

    I don't believe that's supposed to happen in an ideal world, but I thought it would be worth a shot to download a fresh copy of the fetch_5.3.dmg file. (First, I trashed the old one which I had archived in Downloads, plus I trashed the from Applications.)

    Sure enough, after opening the new fetch_5.3.dmg file and dragging to Applications from the Install window, I was able to load Fetch without any issues, and entered my serial number. I was then able to establish a connection with one of my domains, and also was able to create a new shortcut which worked fine.

    I must say that the OSX version of Fetch is so much nicer than the old v4.0 -- it will be a pleasure to use! I guess I'll have to "RTFM" to learn all its new features! :-)

    Now that the loading issue has been resolved, I do have a couple of other questions:

    (1.) Although I had previously removed "" from Home/Library/Preferences, I see that the file has not been recreated after restarting the iMac and browsing the Internet. What purpose does it serve, and should I move the old file (which is currently sitting on my desktop) back to Home/Library/Preferences? (There is still a "" file sitting in Preferences.)

    (2.) Even after creating and saving a new shortcut with v5.3, I noticed that the Home/Library/Preferences folder only contains a Fetch Cache file; it does NOT contain the Fetch Prefs or Fetch Shortcuts files which the v4.0 application created on OS 9.2.2. So, if I wish to transfer shortcuts from G4 to iMac, will anything go awry when I copy the old Fetch Prefs and Fetch Shortcuts files to the iMac's Home/Library/Preferences folder? Or would I be better off simply creating new shortcuts from scratch on the iMac, and not messing with the old prefs files at all?

    (3.) I see that there is a General Fetch Preferences checkbox to "Keep connections alive". Is there any way to set a specific timeout period, other than the default 5 minutes? Does "Keep connections alive" slow down the processor in any way, or increase security risks? Since I believe that dragging a file to a timed-out Fetch window will re-establish the connection, I'm not certain what advantage -- if any -- there might be to "Keep connections alive" -- unless it's to prevent a dial-up connection from timing out at the ISP.

    Again, I appreciate your help -- and look forward to using my shiny new Fetch. :-)

    Posted 11 years ago #

  • Scott McGuire Administrator

    Hi Ian,

    Great, I'm glad to hear that downloading a new copy of the Fetch disk image and reinstalling fixed the problem. Files getting corrupted like that during download is pretty rare, but it can happen.

    And yes, you're right that the sample you sent didn't include much useful data, so I'm glad you found the real solution!

    We're glad to hear that you think the new Fetch looks like an improvement. We do have an extensive set of help files for Fetch 5 - you can access them by choosing Fetch Help from the Fetch menu, or online at the Fetch website, or there is also a PDF of them that you can download. There is a special topic for Fetch 4 users explaining some of the changes we made.

    Regarding your questions:

    (1) The "" is pretty much a legacy file. Way back on Mac OS 9, Internet Config was a way for Internet programs to share common settings; the idea was that the user would only have to set their preferences in one place, and every Internet-using program (such as web, email, and FTP) would read the preferences from Internet Config. While that was a neat idea, it pretty much didn't move forward in Mac OS X. However, some programs still assume the existence of it, so Apple provides legacy support for it. Fetch will still read certain settings from the internetconfig.plist file if it exists; but you will not be missing anything if you don't have it. So, I don't think there's a compelling reason to put it back; but it also probably won't hurt anything to do so if you just want to be sure.

    (2) The reason you don't see new Fetch Prefs or Fetch Shortcuts files even after running Fetch 5.3 and creating a shortcut is that those files have new names in Fetch 5. The Fetch preferences are now stored in a file named com.fetchsoftworks.Fetch.plist, and the Fetch shortcuts are now stored in a file named com.fetchsoftworks.Fetch.shortcuts.plist. (These names follow the standard Mac OS X preference file naming scheme.) Instead of copying the old Fetch Shortcuts and Fetch Prefs file into your Preferences folder at this point, I recommend following the instructions in our help topic on moving shortcuts from one Mac to another. You shouldn't need to do anything besides that to import your shortcuts.

    (3) Yes, Fetch automatically closes a connection after 5 minutes, but reconnects and re-establishes the connection any time you do something in a disconnected transfer window that requires a connection. So no, there is no advantage to the "Keep connections alive" preference for most users; it is there only for very certain circumstances you are unlikely to encounter. (Probably we should move it to the "Miscellaneous" or "Obscure" preferences pane.)

    And no, there is no way to change the time period before Fetch automatically disconnects, beyond checking the "Keep connections alive" checkbox, but since Fetch automatically reconnects when necessary, changing the time before Fetch disconnects really isn't necessary.

    I hope this clarifies things.


    Scott McGuire
    Fetch Softworks

    Posted 11 years ago #

  • Scott McGuire Administrator

    Hi Ian,

    I just wanted to follow up and make sure you were able to get your shortcuts transferred successfully?


    Scott McGuire
    Fetch Softworks

    Posted 11 years ago #

  • dfnet Member

    Hi, Scott! It was wonderfully conscientious of you to follow up this way, and I apologize for not getting back sooner -- as other things managed to distract me along the way! ;-)

    On 10-17-2008, as you suggested, I visited the Fetch Help page on "Moving shortcuts to another Macintosh" at:

    The page explains that "These instructions assume both computers are using Mac OS X." Unfortunately, I could find no reference anywhere on how to move Fetch shortcuts from Mac OS 9.2.2 to OS X.

    It occurred to me that I could try renaming a copy of the OS 9.2.2 file "Fetch Prefs" to "com.fetchsoftworks.Fetch.plist", and a copy of the file "Fetch Shortcuts" to "com.fetchsoftworks.Fetch.shortcuts.plist" -- and then transfer those copies from the G4's "System/Preferences" folder to the iMac's "Home/Library/Preferences" folder (overwriting the files in the latter).

    However, my next reaction was that this could be asking for more trouble than it's worth -- and that it would perhaps be wiser to manually recreate the shortcuts from scratch in Fetch v5.3. After all, I have only a dozen or so shortcuts in v4.0 -- so it won't require too much work.

    That reaction seemed justified after I opened both "Fetch Shortcuts" and "com.fetchsoftworks.Fetch.shortcuts.plist" in text editors on each computer (the G4 9.2.2 and iMac 10.5.5). While each document contains many ASCII characters resembling gibberish, the two do not look very similar in other respects.

    Furthermore, even if the copy-rename-and-transfer process DID work, it probably would not transfer the passwords along with the shortcuts. Mac OS 9.2.2 doesn't appear to use the same Keychain method of storing passwords for different applications. I'm not even sure where to find those passwords in 9.2.2, except by looking for hard copy somewhere.

    I have not yet recreated more than one shortcut manually in Fetch v5.3, since I'm still using v4.0 on the G4 until all my web documents are transferred to the iMac. In the near future, after the transfer is complete, I'll just manually recreate the others -- unless you have some magic prescription that is not covered in Fetch Help. :-)

    Thanks, Scott, for explaining the "" legacy file, and the "Keep connections alive" preference in Fetch. I appreciate all your diligence!

    Posted 11 years ago #

  • Scott McGuire Administrator

    Hi Ian,

    No, you definitely should not rename "Fetch Prefs" to "com.fetchsoftworks.Fetch.plist", and "Fetch Shortcuts" to "com.fetchsoftworks.Fetch.shortcuts.plist" - as you surmised, the formats of the files are completely different in both cases so doing that would just result in errors.

    Sorry, I'd forgotten that you were moving the shortcuts from Mac OS 9.

    These instructions should work for your situation:

    0. Copy the "Fetch Shortcuts" file from your old Mac to your new Mac (I believe you've already done this).
    1. Open Fetch on the new Macintosh.
    2. Cancel the New Connection dialog if it appears.
    3. Choose Shortcuts > Show Shortcuts.
    4. In the Finder, double-click the "Fetch Shortcuts" file from your old computer.
    5. You should now have two shortcut list windows open, both named "Fetch Shortcuts".
    6. Choose Edit > Select All in the window containing your old shortcuts.
    7. Drag the selected shortcuts to the other "Fetch Shortcuts" window.
    8. Close the window containing your old shortcuts.

    In most cases, your passwords should be automatically transferred from the old shortcuts file to the keychain when you do this. Even if they are not, you still have less work to do than re-creating the shortcuts from scratch.


    Scott McGuire
    Fetch Softworks

    Posted 10 years ago #


  • Or nickname, if you prefer.
  • This will be kept confidential.
  • This is to ensure that you’re a person, not a spambot.