Your best friend for file transfer.

Fetch application logoFetch

Fetch 5.8b14 available for testing (1 post)

  • Started 2 weeks ago by Jim Matthews
  • Jim Matthews Administrator

    The current version of Fetch, 5.7.7, is not compatible with macOS 10.15 Catalina.

    I am working on Fetch 5.8, a Catalina-compatible 64-bit version. You can download Fetch 5.8b14, the current beta version, at this link:

    https://fetchsoftworks.com/fetch/download/Fetch_5.8b13.zip

    Fetch 5.8 requires macOS 10.13 High Sierra, 10.14 Mojave or 10.15 Catalina. Please send any feedback about this beta release to https://fetchsoftworks.com/fetch/feedback .

    Thanks!

    Jim Matthews
    Fetch Softworks

    Posted 2 weeks ago #

Reply

  • Or nickname, if you prefer.
  • This will be kept confidential.
  • This is to ensure that you’re a person, not a spambot.