Your best friend for file transfer.

Fetch application logoFetch

Fetch Unexpectedly Quits when closing (2 posts)

  • Started 13 years ago by Aesthetic
  • Latest reply 13 years ago from Scott McGuire
  • Aesthetic Member

    Recently when closing Fetch I get a "Fetch quit unexpectedly" error. Happens every time. I tried downloading the most recent release and still the same problem.

    Running 10.6.7 on an iMac 27"

    Not sure what to check, any ideas?

    Posted 13 years ago #

  • Scott McGuire Administrator


    The first thing you should try is restarting your Mac (go to the Apple menu, and choose Restart), and see if that fixes the problem.

    If you are still experiencing the problem after restarting, we'd like to see a Fetch crash log, which may tell us more about what's causing the problem.

    To find the Fetch crash logs on Mac OS X 10.6:

    * In the Finder, go to the "Go" menu and choose "Home"
    * Open the Library folder
    * Open the Logs folder
    * Open the DiagnosticReports folder
    * Scroll down and find the files whose name begin with "Fetch." Each of the files will have a date in its name. Find the file with the most recent date.

    Please send that file to along with a short description of the problem and we'll investigate.


    Scott McGuire
    Fetch Softworks

    Posted 13 years ago #


  • Or nickname, if you prefer.
  • This will be kept confidential.
  • This is to ensure that you’re a person, not a spambot.