Your best friend for file transfer.

Fetch application logoFetch

FTP Connection – all of: dropped/timing out/not found (2 posts)

  • Started 14 years ago by Sarah J
  • Latest reply 14 years ago from Scott McGuire
  • Sarah J Member

    Hi there,

    I've been trying to establish and FTP for a club I'm (supposed to be) maintaining the website for at my university, UBC. However, the server will just not connect.

    When I'm connected to the Virtual Private Network, it tells me the connection was not established because it "timed out."

    When I'm not connected to the VPN, and just tryin' it out, it tells me "the server dropped the connection. Transcript is now:

    Fetch 5.5.2 (5E703) Intel running on Mac OS X 10.4.11 (8S2167) Intel English
    StuffIt Engine 0x820, StuffIt SDK Version 10.1.1b1
    Expires 01/10/09 T
    Connecting to port 21 (Mac OS X firewall is off) (16/09/09 1:06 AM)
    Connected to port 21 (16/09/09 1:06 AM)
    Update check started at 16/09/09 1:08 AM
    Connecting to port 22 (16/09/09 1:08 AM)
    Update check skipped at 16/09/09 1:09 AM (next check after 22/09/09 8:43 PM)
    Connecting to port 21 (Mac OS X firewall is off) (16/09/09 1:16 AM)
    Connecting to port 21 (Mac OS X firewall is off) (16/09/09 1:20 AM)
    Connecting to port 21 (Mac OS X firewall is off) (16/09/09 1:22 AM)
    Connected to port 21 (16/09/09 1:22 AM)
    Connecting to port 22 (Mac OS X firewall is off) (16/09/09 1:25 AM)

    I asked the web admin at UBC for advise and she said "your firewall must be on." Evidently this is not the case!

    I've just tried again, and Fetch told me under the "dropped connection" alert that I should either try again or verify that the server is running. I have tried at all times of day and the server must be running because another person has been able to update the website.

    Is it possible that I have to be connected to the university's airport to access the server? i.e. that I can't connect from home?

    Any suggestions greatly appreciated.

    Posted 14 years ago #

  • Scott McGuire Administrator

    Hi Sarah,

    I did some tests from my Mac and there was no response to my attempt to connect to, either.

    Usually in those cases, our recommendation is to is double-check that you have the hostname correct. I realize you may have already done this, but might not hurt to check again - you might want to ask the person who was able to update the website what hostname they're using.

    But yes, if that is the correct hostname, then another explanation of why there doesn't appear to be a response would be that the server can only be accessed when you're on the university's network; was the other person who could update the website at the university? The web admin should be able to tell you if you need to be on the campus network. If you do, connecting via the VPN should in theory allow you to connect to the server, because being connected to the VPN should be the same as being on the university's network.

    I don't know why it wouldn't work when you connected via the VPN; I see you were trying both SFTP and FTP, did you try connecting using both when you were connected via the VPN?

    I'm sorry I can't be more specific about how to fix the problem, but I hope this helps a little.

    Please let us know if you haver further questions.


    Scott McGuire
    Fetch Softworks

    Posted 14 years ago #


  • Or nickname, if you prefer.
  • This will be kept confidential.
  • This is to ensure that you’re a person, not a spambot.