Your best friend for file transfer.

Fetch application logoFetch

hello (3 posts)

This is an archived topic. The information in it is likely to be out-of-date and no longer applicable to current versions of Fetch.
  • Started 21 years ago by hyena
  • Latest reply 21 years ago from Jim Matthews
  • hyena Member

    i typed out my post, and i got a "misconfiguration error" when i tried to post it and want to see if i can post before i try to retype the whole thing

    Posted 21 years ago #

  • hyena Member

    I looked back at most of the posts of the past few weeks and didn't see my question. I hope it's not already addressed, if it has been, I apologize for that beforehand.

    Second, I have Fetch 3.0.3 (mostly because I resist change because I'm lazy) and I don't know if this has been changed with Fetch 4 or, also, if this is a question for which I should call the support number or anything, so I apologize if that's the case beforehand, too.

    I need to change my file permissions, and have not been able to Telnet for quite some time. . . I get a "connection refused" on any telnet application I use; and I have tried several with the same results. Previously, I was able to telnet from the same computer with NiftyTelnet to one of the same hosts I have been trying to telnet to presently.

    The significance of this is that I am not significantly versed in Unix and primarily only know how to follow directions. (for example, the directions to a script say to chmod permissions to example.cgi to 755) In Fetch, as well as most other Mac FTP programs (all the ones I've tried), there is only 9 boxes for changing file permissions.

    In short, is there anywhere I can go or anyone to ask to get a translation of which boxes equate to which permissions number? (like, are all 9 boxes the same as "chmod filename 755?) Or could you possibly tell me here which boxes to check for which permissions? =)

    Any response will be appreciated...even a "go to CHI Institute" or "piss off" ... since, lately, 9 times out of ten I get no response.

    Posted 21 years ago #

  • Jim Matthews Administrator

    The short answer is that you want to check all the boxes except for the "Write" boxes in the "Group" and "Everyone" rows. Fetch 4.0.1 translates the 9 checkboxes to the 3-digit Unix permission code as you check the boxes, so it's easier to see the correspondence. Here's a long-winded explanation of what's going on:

    Unix has file permissions for three categories of users, the file's owner, members of the file's group, and everyone else. For each of these three categories there are three permissions that are either on or off: read, write, and search/execute. Search/execute means different things for directories and files; for a directory it means the right to look inside the directory, for a file it means the right to execute the file contents.

    So there's a total of nine switches that are either on or off. In the Unix ls -l listing they are displayed with the letters "r", "w" and "x" (for read, write, and search/execute) if they are on, and "-" if not. So the permission string "rwxrwxrwx" means that all permissions are set; "rwx-r-xr--" means that the owner has read, write and search/execute, the group has read and search/execute, everyone else has only read.

    Permissions are also handled as a three digit octal number, such as 755 or 644. The digits stand for the owner, group, and everyone permissions. Each digit is the sum of read, write, and search/execute, where read is represented by 4, write by 2, and search/execute by 1. So 7 equals 41, or read, write and search/execute. So 755 means that the owner has all permissions, while the group and everyone else only have read and search/execute. You can observe how Fetch translates the "Set Permissions" checkboxes into a three-digit permission code by watching the Fetch Transcript window.

    I hope this helps,

    Jim Matthews
    Fetch Softworks

    Posted 21 years ago #

Topic closed

This topic has been closed.