Your best friend for file transfer.

Fetch application logoFetch

High Sierra killed connection (4 posts)

  • Started 7 months ago by Peter
  • Latest reply 7 months ago from Peter
  • Peter Member

    Using Fetch 4.03 on Mac G4 OS 9.2.2 to send files to Mac Pro. Always worked perfectly. Upgraded to High Sierra and now it won't work at al. I get a message saying server refused the connection. I installed Fetch 5.7 on the Mac Pro, to no avail. In the Mac Pro I tried to make a new connection to the G4 by typing in the IP address, it was refused that way too. I always start the connection in the G4, nothing has changed in that. It must be High Sierra, and i'm desperate to get this working again. Thanks you.
    Peter

    Posted 7 months ago #

  • Jim Matthews Administrator

    Hi,

    I want to start by clearing up a misconception. Fetch is an FTP client and connects to FTP servers. Fetch is not an FTP server, so one copy of Fetch can't connect to another copy of Fetch.

    Since Fetch was able to connect to your Mac Pro your Mac Pro must have been running FTP server software. And now, after upgrading the Mac Pro to High Sierra, it appears that the Mac Pro is no longer running FTP server software. To get this working again you will need to get FTP server software -- either the program that was running on your Mac Pro before the upgrade, or a replacement -- running on your Mac Pro again. One good first step would be figuring out what server software you were using before the upgrade. Years ago Apple included an FTP server with OS X, but I believe that stopped with the release of OS X 10.7 Lion. So my guess is that you had a 3rd party FTP server program, such as Rumpus, CrushFTP, ProFTPD, PureFTPd, vsFTPD, etc.

    I hope this helps,

    Jim Matthews
    Fetch Softworks

    Posted 7 months ago #

  • Peter Member

    Hi, as I said in my email, I have never had any 3rd party server software on the Mac Pro. I did install Fetch on it at the same time I put Fetch on the G4. I always started from the G4. It all worked perfectly under El Capitan until last night when I upgraded to High Sierra. I went through my applications list and found no FTP program. If there's FTP on the G4 I guess I could try to access it from the Mac Pro, but I've always started the process by going from the G4 to the Mac Pro.
    Thanks.
    P

    Posted 7 months ago #

  • Peter Member

    Hi, thanks for the email. I did download the FTP server that was mentioned in the thread. I somehow through trial and error was able to make a shortcut in Fetch on the G4 that takes me to the dedicated transfer folder the FTP server makes on the Mac Pro. I can send files back and forth between the 2 computers pretty easily. The old setup I had was better, in that it showed an image of the Mac Pro from within the G4 and I could do things like drag files from the G4 directly into the dropbox folder on the Mac Pro and have them upload, which was very cool. However, this is better than nothing. Why apple changed this is beyond me.
    P

    Posted 7 months ago #

Reply

  • Or nickname, if you prefer.
  • This will be kept confidential.
  • This is to ensure that you’re a person, not a spambot.