Your best friend for file transfer.

Fetch application logoFetch

I downloaded Fetch... Now where is it? (2 posts)

This is an archived topic. The information in it is likely to be out-of-date and no longer applicable to current versions of Fetch.
  • Started 19 years ago by double
  • Latest reply 19 years ago from Jim Matthews
  • double Member

    I'm VERY new to Fetch, as you probably could've guessed. I just now downloaded it, actually. I hit the download button, and I got a something called Fetch_4.0.3_Store.sit. I tried opening it, and I got the "No default application" thing. How do I actually get the FTP program? Did anybody else have this problem? Please help!

    Posted 19 years ago #

  • Jim Matthews Administrator

    When you tried opening that file it should have opened in StuffIt Expander, which would have converted it into a folder named "Fetch 4.0.3 Folder". You can do that manually by running StuffIt Expander, choosing "Expand..." from the File menu, and selecting the Fetch_4.0.3_Store.sit file.


    Jim Matthews
    Fetch Softworks

    Posted 19 years ago #

Topic closed

This topic has been closed.