Your best friend for file transfer.

Fetch application logoFetch

Invalid PORT Command (2 posts)

  • Started 10 years ago by haildesign
  • Latest reply 10 years ago from Scott McGuire
  • haildesign Member

    I know there are other posts on this subject, but none have helped. I have been using Fetch for a few years now without an issue. I have just been given details for a server so I can upload a new site to it. I have been told the server is Active and I need to use a specific port Number.

    I am on a Mac, using fetch 5.3. I unchecked (and also tried it checked) the PASV checkbox in prefs. I have enabled my firewall to allow connections for Fetch. I have restared fecth a hundred times, but still no luck. I have contacted the server provider and he can access the site via fetch on his mac - without a problem.

    Can anyone help - I'm getting desperate.

    Here's the Log:
    Fetch 5.3 (5D161) Intel running on Mac OS X 10.5.6 (9G55) Intel English
    StuffIt Engine 0x820, StuffIt SDK Version 10.1.1b1
    Partial serial FETCH5X001-PJWM-HJHK T
    Connecting to www.oceangrovetoylibrary.org.au port 2112 (Mac OS X firewall is limiting connections to specific applications) (21/4/09 10:56:40 AM)
    Connected to 203.217.29.29 port 2112 (21/4/09 10:56:40 AM)
    220 Microsoft FTP Service
    USER oceangrovetoylibrary
    331 Password required for oceangrovetoylibrary.
    PASS
    230 User oceangrovetoylibrary logged in.
    SYST
    215 Windows_NT
    PWD
    257 "/oceangrovetoylibrary" is current directory.
    MACB ENABLE
    500 'MACB ENABLE': command not understood
    PWD
    257 "/oceangrovetoylibrary" is current directory.
    TYPE A
    200 Type set to A.
    PORT 10,0,1,199,221,124
    500 Invalid PORT Command.
    PASV
    227 Entering Passive Mode (10,1,1,5,59,183).
    Making data connection to 203.217.29.29 port 15287
    ABOR
    225 ABOR command successful.
    ftp_list: 2,-30000 (state == GETTING_LIST)

    Seems like it logs on fine, but hits a problem with the Port connection... The port needs to be 2112.

    Posted 10 years ago #

  • Scott McGuire Administrator

    Hi,

    My guess is that you are connecting to the Internet through a wireless connection or a router (a device to share your Internet connection between several different computers), is that correct?

    I suspect that the answer is yes, and this is the source of the problem. Due to limitations of how FTP works, you cannot make a successful connection in Active mode to a non-standard port if you are using a device to share your Internet connection with different computers (in technical terms, a NAT device). There are no settings in Fetch you can change to fix this.

    In order to connect successfully, you need to either:

    * Connect your Mac directly to your cable/DSL modem.
    * Convince the server administrator to support passive mode connections, which do not have this problem.

    Please let us know if you have further questions.

    Thanks,

    Scott McGuire
    Fetch Softworks

    Posted 10 years ago #

Reply

  • Or nickname, if you prefer.
  • This will be kept confidential.
  • This is to ensure that you’re a person, not a spambot.