Your best friend for file transfer.

Fetch application logoFetch

Need 'PORT' command first (3 posts)

This is an archived topic. The information in it is likely to be out-of-date and no longer applicable to current versions of Fetch.
  • Started 19 years ago by Jimmy
  • Latest reply 19 years ago from Jimmy
  • Jimmy Member

    I've gone through all 53 pages of topics in the help forum and have tried all possible fixes I could find. I have used Fetch in several different versions for about three years and have never had a problem like this. I can, after several clicks of the OK button, get to the directory on one particular SNAP server, but I cannot view any files there. I also cannot upload files. The message I get is as follows.

    Server file error: Data not implemented for client default data port. Need 'PORT' command first.

    Transcript of requested action is;

    Connecting to port 20 (8/18/04 1:32:53 PM)
    220 Service ready for new user.
    USER public
    331 User name okay, need password.
    230 User logged in, proceed.
    215 UNIX Type: L8 Version: SnapOS.
    257 "/" is your working directory.
    502 Command not implemented.
    CWD darran
    250 Requested file action okay, completed.
    257 "/darran" is your working directory.
    PORT 192,168,0,10,126,28
    200 Command okay.
    425 Can't open data connection.
    ftp_list: -30000 (state == GETTING_LIST)
    257 "/darran" is your working directory.

    I've tried switching ports as well as switching from passive to non-passive transfers. I get the file error message at each get directory instance. Any help will be appreciated.

    Posted 19 years ago #

  • Jim Matthews Administrator

    There is a known problem with Fetch 4.0.3 that keeps it from working in passive mode with Snap servers. The first thing I'd recommend trying is getting it to work in non-passive mode. The transcript you posted shows that not working -- do you have the OS X firewall feature turned on? If so, I'd try turning it off.

    If you can't get Fetch working in non-passive mode please send an email to bugs @ and I'll see about getting you a test version that fixes this problem.


    Jim Matthews
    Fetch Softworks

    Posted 19 years ago #

  • Jimmy Member

    Thanks for the quick response. I have tried all the data ports that the client I'm having the problem with's IT guy says are avaliable for ftp access. I have done so in passive and in non-passive mode with the OSX firewall turned off. I'm behind two hardware firewalls. All other clients with ftp access work fine from the same computer/network access point. I will e-mail the mailbox you gave me tommorrow from my work adress.

    Thanks again,

    Posted 19 years ago #

Topic closed

This topic has been closed.