Your best friend for file transfer.

Fetch application logoFetch

No File list...OS X...4.0.2 (3 posts)

This is an archived topic. The information in it is likely to be out-of-date and no longer applicable to current versions of Fetch.
  • Started 20 years ago by das
  • Latest reply 20 years ago from das
  • das Member

    a weird one here:

    using 4.0.2 on a beige g3 running os x, can't ftp to one site, but can to all my others. on occasion, i have ftp'd to this site. i tried another ftp client, captain ftp, but that also didn't work. haven't tried from the g3 using 9.2.2 yet. however, from an os 9.2 g4, i can ftp into this site using fetch 3.0.3.

    i have tried turning passive both on and off at the application level and at the system level. can traceroute to the ip on port 21. everything seems to be kosher.


    Connecting to .com port 21 (08/10/02 4:27:23 PM)
    220-=(<*> )=-.:. (( Welcome to PureFTPd 1.0.0 )) .:.-=(<*> )=-
    220-You are user number 4 of 50 allowed
    220-Local time is now 16:14 and the load is 0.00. Server port: 21.
    220 You will be disconnected after 15 minutes of inactivity.
    502 Security extensions not implemented
    USER mike
    331 User OK. Password required
    230-User has group access to: users
    230 OK. Current directory is /home/mike
    215 UNIX Type: L8
    257 "/home/mike" is your current location
    500 Unknown command
    257 "/home/mike" is your current location
    227 Entering Passive Mode (66,93,79,121,141,69).
    CStreamOT::Read() OTRcv() returned -3259
    get_reply():con_conn->Getline() returns -3259
    ftp_list: -3259 (state == GETTING_LIST)

    the weird thing is that when i hit stop, fetch crashes.

    any thoughts?

    Posted 20 years ago #

  • Jim Matthews Administrator

    This sort of problem is usually caused by firewalls (or firewall software) on one or both sides of the connection. If you can ftp from the G3 running Mac OS 9 that might suggest an issue with firewall software installed on OS X. Another thing to try is the command line FTP client in OS X -- type "ftp hostname" in Terminal, and "dir" after you connect to get a file list.


    Jim Matthews
    Fetch Softworks

    Posted 20 years ago #

  • das Member

    so the solution to this issue turns out to be the following:

    the firewall in os x needs to have incoming ftp services turned on and passive tuned off in both fetch and os x.

    very weird.

    thanks though.

    Posted 20 years ago #

Topic closed

This topic has been closed.