Your best friend for file transfer.

Fetch application logoFetch

No Such File (Errror -30000 ftp_retreive (state== GETRETRIEVING) (3 posts)

This is an archived topic. The information in it is likely to be out-of-date and no longer applicable to current versions of Fetch.
  • Started 20 years ago by geoffc
  • Latest reply 20 years ago from geoffc
  • geoffc Member

    Lots of references to 30000 errors, but all in putting files. Here is one where I am trying to open a directory to read the listing, and I get the error.

    ftp_retrieve: -30000 (state == GET_RETRIEVING)

    In this case, Novell NWFTPD (tried it on 3 different revs, the latest, and a couple of older revs). Mac OS X 10.2.3 and Fetch 4.01 and 4.03, all have the issue. Works fine on Mac OS 9.2.2 and Fetch 4.01 (Freaky, eh?)

    Starts in the users home dir, then go up one dir, but cannot go back down to thier home dir. They DO have rights to thier dir, and if you use Change Directory it works. If you use Directories and the list and select the home dir, it can get there as well.

    I just cannot browse back down to it. Very odd. Any ideas?

    Posted 20 years ago #

  • Jim Matthews Administrator

    Could you post a transcript of the error (on OS X), and a transcript of the same actions working (on OS 9)? Choose "Fetch Transcript" from the Window to open the Fetch Transcript window. I'm curious to see how the transcripts compare.


    Jim Matthews
    Fetch Softworks

    Posted 20 years ago #

  • geoffc Member

    This is the freakiest thing! I went to do as you requested, and it suddenly worked. I could reproduce it on 3 servers, with different accounts! And now suddenly it worked. Something really wierd is happening here!

    I can have the error happen when I am allowed to see a server volume, but do not have rights to it. (On the Novell FTP server you can see all the volumes on a server, but you can only browse the contents with rights). But in the case i was reporting on, the user most definitly had correct rights, as it opened up there as thier home dir, and was manipuatable!

    I will keep testing and see if it comes back.

    Posted 20 years ago #

Topic closed

This topic has been closed.