Your best friend for file transfer.

Fetch application logoFetch

Permissions Problems (2 posts)

  • Started 9 years ago by loopydloop
  • Latest reply 9 years ago from Scott McGuire
  • loopydloop Member

    Greetings. I have been using Fetch successfully for years and love the application. However, I recently upgraded my computer to Leopard and, to my surprise, the next time I tried to log on to Fetch on my desktop machine I was told in a dialog box that I did not have permissions to do so. I thought this strange as that hadn't happened before and I had changed nothing. So, I repaired preferences and restarted. Same thing. Now, I am the only user of my machine and I am and have always been logged in as the same user. How could this suddenly change and I would not have permission on my own computers. Also, interestingly, this seems to be somehow connected with the keychain in the Max OS system. If I don't check the remember in key chain command it lets me log on. Also, ALSO, I am able to log on as I always have on my new laptop, which is also using Leopard. Any thoughts on this? I've tried a lot of different methods to fix this. Nothing seems to work. I even thought that, if I took the application out of my system, downloaded it again and installed it again it would work with the permissions for my User, but when I remove the application and then reinstall from a new download I am right where I left off. It never asks for my key code it just remembers the last installation and starts as if I never took the app out of the system. How about THAT! Any help would be appreciated.

    Dave

    Posted 9 years ago #

  • Scott McGuire Administrator

    Hi Dave,

    Despite the use of the word "permissions" in the error message, this error actually indicates a problem with the Mac OS X keychain (as you suspected). Unfortunately the error message comes from Mac OS X, not Fetch, so we can't fix the wording to be more helpful!

    As you may know, Fetch uses the keychain to securely store the passwords for your shortcuts and recent connections. Unfortunately, the upgrade to Leopard has caused keychain problems for quite a few people, and the problems can affect Fetch.

    There are a couple of things to try that should fix the problem.

    First, choose Software Update from the Apple menu and check for updates. You should install both the "Login & Keychain Update for Leopard" and the "Mac OS X 10.5.1" update if you haven't already. These both include Keychain fixes. Then restart your Mac, if you haven't been required to by the update process.

    Try Fetch again. If the updates haven't helped, or you've already installed both updates, next please do the following:

    * Quit Fetch, if it's running.
    * Open the Keychain Access application, which is in the Utilities folder inside your Applications folder.
    * Go to the Keychain Access menu, and choose Preferences.
    * Click on the "First Aid" tab.
    * Make sure both "Synchronize login keychain password" and "Set login keychain as default" are checked.
    * Then go to the Keychain Access menu, and choose Keychain First Aid.
    * In the password field of the Keychain First Aid window, enter your Mac OS X admin password (this should be the same as your Mac OS X login password).
    * Click the Repair radio button.
    * Click the Start button.
    * Once it's done, close the Keychain First Aid window.
    * Restart your Macintosh.

    Then try Fetch again.

    Let us know if either of these helps, or if you're still having problems.

    Thanks,

    Scott McGuire
    Fetch Softworks

    Posted 9 years ago #

Reply

  • Or nickname, if you prefer.
  • This will be kept confidential.
  • This is to ensure that you’re a person, not a spambot.