Your best friend for file transfer.

Fetch application logoFetch

Rollback to 5.5 (5 posts)

  • Started 13 years ago by Dayo
  • Latest reply 13 years ago from Scott McGuire
  • Dayo Member

    Where can I find a copy of v5.5?

    I need to roll back as my IMac G5 has been acting funny since I upgraded to 5.6.

    The whole machine basically locks up whenever an upload or download is in progress.

    I thought It was supposed to be universal binary but something just doesn't sit right. Even the little Icon that normally sits in the bottom left showing progress is just a square box.

    I also notice it is uploading text files as binary. I have automatic selected and it has worked fine for heaven knows how many years.

    Anyway, I need to get back to 5.5.


    Posted 13 years ago #

  • Scott McGuire Administrator


    We can tell you how to downgrade to Fetch 5.5 if necessary, but the behavior you are experiencing with Fetch 5.6 is definitely not normal and we'd like to try to find out what's going on and fix it if possible.

    Fetch 5.6 is definitely a Universal Binary and should work fine on an iMac G5; we have tested it on PowerPC Macs.

    Have you tried downloading a fresh copy of Fetch 5.6 to see if that makes a difference?

    * Quit Fetch if it's running.
    * Open your Applications folder, and put the Fetch application in the Trash.
    * If you still have the Fetch_5.6.dmg file, put that in the Trash, too.
    * Download a new copy of Fetch using this link: .
    * Install the newly downloaded copy of Fetch.

    Try running Fetch again.

    Does that make a difference?


    Scott McGuire
    Fetch Softworks

    Posted 13 years ago #

  • Dayo Member

    No joy.

    Here is a excerpt from my transcript

    Connecting to port 22 (9/25/10 10:00 AM)
    SSH2_FXP_STAT 2, /root
    SSH2_FXP_REALPATH 3, /path/to/my/site/httpdocs/path/to/css
    SSH2_FXP_STAT 4, /path/to/my/site/httpdocs/path/to/css
    SSH2_FXP_OPEN 5, /path/to/my/site/httpdocs/path/to/css/stylesheet.css [ SSH2_FXF_READ ]
    SSH2_FX_OK 8
    Successful download of stylesheet.css as binary data (0 bytes, 0 bytes/sec, 1:38 elapsed) completed at 9/25/10 10:02 AM

    It locks up the machine while this is going on, takes a long time to complete and as said, the icon is just a square grey box (on the dock as well).

    I did upgrade to Safari 5.02 around the same time and the freeze up seems to be worse, and the time taken longer when Safari is running so not sure if it is related.

    Posted 13 years ago #

  • Dayo Member

    I noticed some other apps were being flaky as well so I ran various cleanup stuff with OnyX and things are back to normal.

    Thanks for making such a cool app!

    Posted 13 years ago #

  • Scott McGuire Administrator


    You're welcome, and we're glad to hear that things seem to be back to normal.

    Fetch is a self-contained program and so can't cause problems with other programs on your Mac; so if you start experiencing problems with multiple applications, the problem almost always lies elsewhere - as you discovered.

    Please let us know if you have any further questions or problems.


    Scott McGuire
    Fetch Softworks

    Posted 13 years ago #


  • Or nickname, if you prefer.
  • This will be kept confidential.
  • This is to ensure that you’re a person, not a spambot.