Your best friend for file transfer.

Fetch application logoFetch

Slow to connect to server (2 posts)

  • Started 18 years ago by Sensei
  • Latest reply 18 years ago from Jim Matthews
  • Sensei Member

    Am using Fetch 5 to connect to an OSX (UNIX) ftp server. The server is not behind a firewall, but it is behind a router running NAT. My computer is also behind a router doing NAT. No firewall on my computer either.
    When connecting to the ftp server via port 20 (sftp) using Interarchy (sorry!), the remote directory listing pops up immediately. Same result using port 16080 in a browser. However when connecting over port 21 (ftp) in Fetch 5, it takes at least 12-14 seconds before I see the listing. I have toggled PASV on/off, same result. What might be causing this slow response? Thanks very much

    Posted 18 years ago #

  • Jim Matthews Administrator

    Have you tried connecting with Fetch using SFTP?

    Does Refreshing the file list go more quickly than the initial download?

    You might try connecting with the Fetch Transcript open, and see if you can spot when (i.e. after which command) the delay is occuring.


    Jim Matthews
    Fetch Softworks

    Posted 18 years ago #


  • Or nickname, if you prefer.
  • This will be kept confidential.
  • This is to ensure that you’re a person, not a spambot.