Your best friend for file transfer.

Fetch application logoFetch

Two problems with Fetch 4.0 (5 posts)

This is an archived topic. The information in it is likely to be out-of-date and no longer applicable to current versions of Fetch.
  • Started 17 years ago by Juli
  • Latest reply 17 years ago from Jim Matthews
  • Juli Member

    Hi, the new Fetch is FANTASTIC! I love the new features so much - just what I would have asked Santa for! (esp. being able to view files by category, and that it uses that newer version of Mac OS window when you go to open files; no idea what it's called, but allows you to choose favorites and all of that. Makes life so much easier)

    Now...my two problems. I know these are specific to Fetch 4, because I've used Fetch 3.x forever without this problem.

    1. Uploading rm (real player) files. I had a series of new files to upload, which included some gifs/jpgs, html pages, ram files (small txt files to tell Real Player where to go), and rm files (the multimedia files). Like I always do on files that take awhile, I set it to upload them all and then went to do something else. Ooops. Came back and it had uploaded all the files fine, except the rm files. Plus, it crashed (no error message at all) and I had to force reboot. Tried a few more times, and same thing. So then I uploaded the text files...fine, no problem. I uploaded one rm file (about 3 mb) and it again crashed on me. No error message. I finally ended up pulling out my old Fetch, and it worked just fine, as it always has.

    2. CGI scripts. I tend to use the raw data setting for everything; that has always worked for me. So I uploaded a modified CGI script and started getting server errors. It took me awhile to pinpoint the problem, but it's because I used the raw data setting. In order to successfully upload cgi scripts, I now have to use the text setting, or I'll get a server error. I've made the mistake enough times now to know that if I forget to override raw data and batch upload, then get any kind of server error, I need to go back and reupload the cgi file using text. The old fetch never did this - I could batch a bunch of different kinds of files using raw data, and it all worked just fine.

    These aren't major problems to me, because I've got my old Fetch on standby, but thought you might want to know.

    Fetch is a fantastic thing! One of the most reliable, sturdy pieces of software alive. Once I found Fetch, I've never even bothered with another ftp software.

    Juli

    [This message has been edited by Juli (edited 06-15-2001).]

    Posted 17 years ago #

  • darien Member

    This one needs to go into the FAQ:

    In the menubar under CUSTOMIZE, choose SUFFIX MAPPING...

    Add as many different suffixes (.cgi, .pl, .rm) as you need and the type of transfer that Fetch should use (binary/raw, text).

    Then when you transfer files, Fetch knows which way to do it.

    (Many of these common suffixes should have been included with the Fetch 4 release, in my opinion, but its easy enough to add them once and be done with it.)

    Posted 17 years ago #

  • Juli Member

    Thank you!

    Posted 17 years ago #

  • AlVal Member

    In response to the response to complaint 2:
    Unfortunately, this doesn't work in Mac OS X. Since the new OS doesn't use Internet Config, Fetch doesn't know how to map the suffixes. I have had this probelm repeatedly... *.cgi is not mapped as text, so all newlines (when looked at using emacs on the remote UNIX system) appear as ^M. I am unsure how to fix it in OS X.

    Alex

    Posted 17 years ago #

  • Jim Matthews Administrator

    On Mac OS X you can edit suffix mappings by first unchecking the "Use Internet Config" box in the General section of Preferences. That should probably be the default.

    Thanks,

    Jim Matthews
    Fetch Softworks

    Posted 17 years ago #

Topic closed

This topic has been closed.