Your best friend for file transfer.

Fetch application logoFetch
Fetch Icon Fetch Help > Transfer Window Toolbar

The toolbar at the top of transfer windows provides easy access to frequently used commands.

Fetch ships with a default set of buttons in the toolbar, but you can add other buttons, remove any of the default ones, or return the toolbar to its original state. See below for a complete list of the buttons available and a short description of what they do.

To customize the toolbar:

Choose View > Customize Toolbar, or Control-click in the toolbar and choose Customize Toolbar from the contextual menu.

You can also hide the toolbar, or change it to show smaller icons or only icons or only text.

To hide the toolbar:

Choose View > Hide Toolbar. To show it again, choose View > Show Toolbar. You can also click the toolbar button in the upper-right corner of the transfer window.

To change the appearance of the toolbar:

Control-click in the toolbar and choose one of the following options:

  • Icon & Text - Show both icons and names in the toolbar
  • Icon Only - Show toolbar buttons as icons without names
  • Text Only - Show toolbar buttons as only names
  • Use Small Size - Display the icons and names at a smaller size

The default buttons in the toolbar are listed below. Select a button title for more information.

Go back to the remote folder you were viewing before the current one.
Click this button to display a list of all the folders that contain the current one. Choose a folder to go to it.
Click this button to display a list of folders you've recently visited on the current server. Choose a folder to go to it.
Download one or more files or folders from a server to your Macintosh.
Upload one or more files or folders from your Macintosh to a server.
Quick Look
Display files on a server without leaving Fetch. Many different kind of files can be displayed, including text files, images, sounds, movies, PDFs, and Microsoft Word and Excel files.
Edit files in an editor application and save changes back to the server automatically.
Get Info
Display a window containing detailed information about the selected remote files or folders, and lets you rename or set permissions on the items.
Display the currently selected items in your web browser (or set up WebView for the current server, if necessary). The WebView button's icon will always be the icon of your default web browser, so the icon may be different if you have set a browser other than Safari as your default web browser.
New Folder
Make a new folder on the server.
Delete files or folders on a server.

The optional items that you can add to the toolbar are listed below. Select a button title for more information (if available).

Choose which format to use when putting or uploading files to the server.
Go to Folder
Change to another folder on the server by typing its name or path.
Take you to your home folder on the server.
Show the Mirror window, where you can copy all the new or changed files from a Macintosh folder to a server folder, or vice versa.
Choose what mode (automatic, text, or binary) to use when getting or downloading files from a server.
New Shortcut
Create a new shortcut to access remote files or folders quickly.
Change the current folder to be the parent folder of the folder you're currently viewing, that is, go up one level. You can drag items to the Parent button to move them to the parent folder.
Resume Download
Resume partially completed downloads.
Send FTP Commands
Send arbitrary FTP commands to an FTP server, with special support for searching (SITE INDEX) and setting upload permissions.
View as Text
View files on a server as plain text without leaving Fetch.
Insert a vertical line in the toolbar so you can group items together.
Flexible Space
Insert blank space in the toolbar between items.
Display the Customize Toolbar dialog.