Your best friend for file transfer.

Fetch application logoFetch

Emac ,os 9.2 (2 posts)

  • Started 1 year ago by jim
  • Latest reply 1 year ago from Jim Matthews
  • jim Member

    will fetch work on OS 9.2 or panther. doesn't have to be

    Posted 1 year ago #

  • Jim Matthews Administrator


    Older versions of Fetch are available for download at

    For Mac OS 9.2 you'd want Fetch 4.0.3. For Panther (aka OS X 10.3) you'd want Fetch 5.3.1 (as long as you have 10.3.9).


    Jim Matthews
    Fetch Softworks

    Posted 1 year ago #


  • Or nickname, if you prefer.
  • This will be kept confidential.
  • This is to ensure that you’re a person, not a spambot.