Your best friend for file transfer.

Fetch application logoFetch

Fetch 4 not working on an imac (6 posts)

This is an archived topic. The information in it is likely to be out-of-date and no longer applicable to current versions of Fetch.
  • Started 13 years ago by smita
  • Latest reply 13 years ago from smita
  • smita Member

    This is a strange problem: I've got Fetch 4 installed on my G4 and it works beautifully. But, I tried to install it on a colleague's imac so she could download data from from our server. It seemed to install fine, and it accepted the ftp information, but then the dog just kept running and running. In the meantime, I was able to connect almost instantly from my computer. (We're on a network and a shared DSL connection, so I can't imagine how it could be a firewall issue).

    We then tried installing Fetch 3 on the imac and that did connect. But the data that we download with Fetch 3 does not import correctly into our database (the data downloaded via Fetch 4 works beautifully with our database).

    Any advice would be greatly appreciated! Thanks!

    Posted 13 years ago #

  • Jim Matthews Administrator

    I suspect some difference in configuration between the two computers. One idea would be to transfer the Fetch Prefs file from the G4 to the iMac. Another possibility is to compare the transcripts (from the Fetch Transcript window) between the two.

    Thanks,

    Jim Matthews
    Fetch Softworks

    Posted 13 years ago #

  • smita Member

    Thanks Jim! Putting the G4's Fetch Prefs into the IMAC worked like a charm as far as getting connected to the server is concerned. However, we then ran into a new problem:

    When we tried to download a text file from the server, it appeared on the desktop with a broken Fetch icon and we were unable to open it. Even more strange, when I kept downloading it, the file downloaded correctly on about the third try after quitting and reconnecting . But then it stopped and didn't download correctly until the 6th try. We re-started and then it didn't work the first time but did work the second time. Over the course of 20 minutes of playing, we were unable to find a consistent pattern. Finally, I found that if I simply dragged the file instead of using the "Get File" command, it worked.... Any idea what I'm doing wrong here?

    Thanks!!! -smita

    Posted 13 years ago #

  • Jim Matthews Administrator

    That's very curious. If that's the way things usually go I'd be interested in seeing the contents of the Fetch Transcript window (it's listed in the Window menu). I take it that you can download this file to the G4 without problems?

    Jim Matthews
    Fetch Softworks

    Posted 13 years ago #

  • Kaiousama Member

    Didn't notice if you said you got it working. My school had the same problems with its new Titanium G4 Macs. We couldn't even break through a firewall, but sometimes the fetch seems to set itself to a different port than most servers on on. In most cases port 21 will be the server that you need to use to connect to a serve,r unless the server says something different than that.

    If you haven't tried this, and still haven't gotten it to work, oyu might try going to your preferences and checking out the port numbers.

    Posted 13 years ago #

  • smita Member

    Great idea Kaiousama, thanks! Jim had suggested using the passive mode, and that worked to get the data once we were connected, but we were not able to connect in passive mode. My server administrator scolded me for switching midstream between active and passive and suggested getting him a static IP address that he could tell the firewall to allow in. But I've not managed to do that yet. In the meantime, we are able to connect to the sever, but the data downloads correctly sometimes and not others. I'll check out port 21.
    Thanks!
    smita

    Posted 13 years ago #

Topic closed

This topic has been closed.