Your best friend for file transfer.

Fetch application logoFetch

Get Info Bugs (7 posts)

  • Started 9 years ago by davedit
  • Latest reply 9 years ago from Jim Matthews
  • davedit Member

    Upon further testing of the latest beta of Fetch, I ran into two bugs. I was curious if you guys were aware of these.

    1) In both 5.0.2 and 5.0.3b1, I've had a sporadic error when getting info on a file. Most of the time it works, but occassionally, I'll get hit with this error: "The action could not be completed because a file was not found." Not sure why this happens because there's nothing wrong with the file. A simple restart of Fetch solves the problem, but it comes creeping back occasionally.

    2) When you get info on a file whose file name is longer than the text box in the Get Info window, the text cursor can act a little screwy. It's a little hard to describe this... If you move the text cursor to the end of the file name (on the right side), and then push the left arrow to move the text cursor to the left, I believe the normal behavior would be for text cursor to simple move to the left (and when you get the left side of the text box, the box starts moving), but instead, the entire box moves to the left, so the text cursor remains at the far right of the box. This keeps happening until you can see the beginning of the file name, at which point only the cursor moves to the left. Is this intentional?

    Posted 9 years ago #

  • Scott McGuire Administrator

    Hi,

    (1) A couple of questions regarding the "file not found" error. Do you usually get this error on files you've just uploaded? Does it go away if you refresh the file list, instead of restarting Fetch?

    The next time you get the error, if you could post or send the contents of the Fetch Transcript to us, that would be helpful.

    (2) I can confirm this behavior. I agree it's not quite what you might expect and we'll take a look at it, but it may be an OS problem; if you get info on file with a long name in the Mac OS X 10.3.9 Finder, you'll see the same behavior.

    Thanks,

    Scott McGuire
    Fetch Softworks

    Posted 9 years ago #

  • davedit Member

    1) Actually, once I get the error, then I get the error if I try to Get Info on ANY file after that. And refresh doesn't fix the problem unfortunately. I tried looking in the transcript when the error came up, but nothing shows up in the transcript regarding the error.

    2) Ooh I see. Thanks!

    Posted 9 years ago #

  • Scott McGuire Administrator

    That's puzzling about the error. Please download and install Fetch 5.0.3 final (if you haven't already), and the next time you get the error, could you run Console (it's in the Utilities folder inside the Applications folder), open the Console log, and post or send us all the Fetch-related error messages that you will see at near the bottom of the console window?

    Also, posting or sending the transcipt information would be helpful since it will tell us something about your setup (in particular, the StuffIt version and the type of server you are connecting to).

    Thanks,

    Scott McGuire
    Fetch Softworks

    Posted 9 years ago #

  • davedit Member

    Yeah I just installed 5.0.3, I'll get back to you if/when I see the error again!

    Posted 9 years ago #

  • davedit Member

    Just wanted to say that I'm yet to see this problem surface in 5.0.4!

    Posted 9 years ago #

  • Jim Matthews Administrator

    That's good -- thanks for following-up!

    Jim Matthews
    Fetch Softworks

    Posted 9 years ago #

Reply

  • Or nickname, if you prefer.
  • This will be kept confidential.
  • This is to ensure that you’re a person, not a spambot.