Your best friend for file transfer.

Fetch application logoFetch

Help with MS Proxy 2.0 (4 posts)

This is an archived topic. The information in it is likely to be out-of-date and no longer applicable to current versions of Fetch.
  • Started 13 years ago by Todd Freese
  • Latest reply 13 years ago from Jim Matthews
  • Todd Freese Member

    I am having trouble connecting through a MS Proxy 2.0. I have it selected in the Firewall Prefs and have the IP and port set. When I try to connect, I get the first listing. When I try to move down a directory, I get the following error: "Can't Open Data connection."

    Here is a transcript:
    NOT_CONNECTED -> NOT_CONNECTED 0
    ftp.4d.com NOT_CONNECTED -> CONNECTING 0
    Connecting to ftp.4d.com port 21 (3/19/01 8:26:08 AM)
    ftp.4d.com CONNECTING -> ABORTING 0
    ftp.4d.com ABORTING -> IDLE_DISC 0
    ftp.4d.com IDLE_DISC -> NOT_CONNECTED 0
    NOT_CONNECTED -> NOT_CONNECTED 0
    ftp.4d.com NOT_CONNECTED -> CONNECTING 0
    Connecting to ftp.4d.com port 21 (3/19/01 8:26:53 AM)
    ftp.4d.com CONNECTING -> ABORTING 0
    ftp.4d.com ABORTING -> IDLE_DISC 0
    ftp.4d.com IDLE_DISC -> NOT_CONNECTED 0
    NOT_CONNECTED -> NOT_CONNECTED 0
    ftp.4d.com NOT_CONNECTED -> CONNECTING 0
    Connecting to ftp.4d.com port 21 (3/19/01 8:27:33 AM)
    220 ftp4d Microsoft FTP Service (Version 5.0).
    ADAT
    500 'ADAT Hi there, do you support security?': command not understood
    USER anonymous
    331 Anonymous access allowed, send identity (e-mail name) as password.
    PASS
    230-Welcome to 4D FTP Site
    230 Anonymous user logged in.
    ftp.4d.com CONNECTING -> SENDING_PBSZ 0
    ftp.4d.com SENDING_PBSZ -> SENDING_PROT 0
    ftp.4d.com SENDING_PROT -> GETTING_INFO 0
    SYST
    215 Windows_NT version 5.0
    PWD
    257 "/" is current directory.
    MACB ENABLE
    500 'MACB ENABLE': command not understood
    SITE DIRSTYLE
    200 MSDOS-like directory output is on
    SITE DIRSTYLE
    200 MSDOS-like directory output is off
    ftp.4d.com GETTING_INFO -> GETTING_WD 0
    PWD
    257 "/" is current directory.
    ftp.4d.com GETTING_WD -> GETTING_LIST 0
    PASV
    227 Entering Passive Mode (216,33,0,202,18,67).
    LIST
    125 Data connection already open; Transfer starting.
    dr-xr-xr-x 1 owner group 0 Oct 13 2000 !__HOT_FTP_(New_This_Month)
    -r-xr-xr-x 1 owner group 1474 Apr 27 2000 !_Info_on_files_found_here.txt
    dr-xr-xr-x 1 owner group 0 Mar 31 2000 ACADEMIC
    dr-xr-xr-x 1 owner group 0 Apr 27 2000 ACI_PRODUCT_ARCHIVE_(V6)
    dr-xr-xr-x 1 owner group 0 Jun 14 2000 ACI_PRODUCT_ARCHIVE_(V6.5)
    dr-xr-xr-x 1 owner group 0 Feb 9 11:51 ACI_PRODUCT_REFERENCE_LIBRARY
    dr-xr-xr-x 1 owner group 0 Oct 23 2000 ACI_PRODUCTS_(Current_Release)
    dr-xr-xr-x 1 owner group 0 Apr 27 2000 ACI_PRODUCTS_DEMO_VERSIONS
    dr-xr-xr-x 1 owner group 0 Jan 29 16:26 ACI_TECHNICAL_NOTES
    d--------- 1 owner group 0 Apr 27 2000 PARTNER_SERVICES_(restricted)
    dr-xr-xr-x 1 owner group 0 Apr 27 2000 PRESS
    dr-xr-xr-x 1 owner group 0 Feb 5 14:26 PRODUCTS
    dr-xr-xr-x 1 owner group 0 Jul 14 2000 PUBLIC
    dr-xr-xr-x 1 owner group 0 Jan 15 14:13 SAMPLE_DATABASES
    dr-xr-xr-x 1 owner group 0 Nov 29 2000 WebSTAR_Update
    dr-xr-xr-x 1 owner group 0 Apr 27 2000 YEAR_2000_INFORMATION
    226 Transfer complete.
    ftp.4d.com GETTING_LIST -> IDLE 0
    ftp.4d.com IDLE -> GET_CHGING_DIR 0 ACI_PRODUCTS_(Current_Release)
    CWD ACI_PRODUCTS_(Current_Release)
    250 CWD command successful.
    ftp.4d.com GET_CHGING_DIR -> GETTING_WD 0 ACI_PRODUCTS_(Current_Release)
    PWD
    257 "/ACI_PRODUCTS_(Current_Release)" is current directory.
    ftp.4d.com GETTING_WD -> GETTING_LIST 0 ACI_PRODUCTS_(Current_Release)
    PASV
    227 Entering Passive Mode (216,33,0,202,18,68).
    LIST
    425 Can't open data connection.
    ftp_list: -30000 (state == GETTING_LIST)
    ftp.4d.com GETTING_LIST -> IDLE 0 ACI_PRODUCTS_(Current_Release)

    Posted 13 years ago #

  • Jim Matthews Administrator

    You might try unchecking the "Use passive mode transfers (PASV)" box in the Firewall section of Preferences, to see if that makes a difference. You should also make sure that the proxy server has the latest service pack installed.

    Jim Matthews
    Fetch Softworks

    Posted 13 years ago #

  • Todd Freese Member

    I have tried it with and without PASV. I am running SP1 for Proxy. Any other ideas?

    Todd

    Posted 13 years ago #

  • Jim Matthews Administrator

    Grambo, in another thread, had success with these settings:

    General settings:
    Use Internet Config: not selected

    Firewall settings:
    Use PASV: selected
    Proxy type: Socks 4.3 (or MS Proxy 2.0)
    Proxy host: Ip address of host
    Port: empty
    Proxy user ID: Domainusername
    Proxy Password: ********
    Dont use Proxy for: empty

    And in the TCP/IP control panel, unchecking "Load only when needed". Do these settings work for you?

    Posted 13 years ago #

Topic closed

This topic has been closed.