Your best friend for file transfer.

Fetch application logoFetch

Problems uploading podcast page (7 posts)

  • Started 7 years ago by mattshort
  • Latest reply 7 years ago from Scott McGuire
  • mattshort Member

    I had a few mistakes in my podcast page so, I fixed them in iweb and tried to upload the changes to my site using Fetch. It stops on the Podcast page (everytime) saying the file already exists. I tried deleting everything from the server (using Fetch). I tried renaming the Podcast page in iweb but, nothing seems to work. I've already submitted the podcast in itunes (before I made the changes) but, haven't received any confirmation yet. Any ideas?
    Thanks

    Posted 7 years ago #

  • Scott McGuire Administrator

    Hi,

    We'd like some more information to help diagnose the problem. Could you please do the following?

    * Quit Fetch, if it's running.
    * Open Fetch again.
    * Connect to your server.
    * Try uploading again.
    * Then choose Fetch Transcript from the Window menu, copy the entire contents of the transcript window, and paste them into a reply to this message.

    Thanks,

    Scott McGuire
    Fetch Softworks

    Posted 7 years ago #

  • mattshort Member

    Fetch 5.2 (5C121) PowerPC running on Mac OS X 10.4.8 (8L127) PowerPC English
    StuffIt Engine 0x820, StuffIt SDK Version 10.1.1b1
    Partial serial FETCH5X001-B23K-2EP3 T
    Connecting to www.huntingjunky.com port 21 (Mac OS X firewall is off) (5/7/07 4:25:56 PM)
    Connecting to www.huntinjunky.com port 21 (Mac OS X firewall is off) (5/7/07 4:26:11 PM)
    Connected to 68.178.254.198 port 21 (5/7/07 4:26:12 PM)
    220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
    220-You are user number 2 of 50 allowed.
    220-Local time is now 13:26. Server port: 21.
    220-This is a private system - No anonymous login
    220 You will be disconnected after 3 minutes of inactivity.
    USER mattshort1
    331 User mattshort1 OK. Password required
    PASS
    230-User mattshort1 has group access to: 600
    230 OK. Current directory is /
    SYST
    215 UNIX Type: L8
    PWD
    257 "/" is your current location
    MACB ENABLE
    500 Unknown command
    PWD
    257 "/" is your current location
    TYPE A
    200 TYPE is now ASCII
    PASV
    227 Entering Passive Mode (68,178,254,198,32,86)
    Making data connection to 68.178.254.198 port 8278
    LIST -al
    150 Accepted data connection
    drwx---r-x 6 1072 600 4096 May 6 17:40 .
    drwx---r-x 6 1072 600 4096 May 6 17:40 ..
    drwxr-xr-x 8 1072 600 4096 May 7 13:24 Huntin' Junky
    drwx---r-x 2 1072 600 4096 May 6 06:39 cgi
    -rwx---r-x 1 1072 600 0 May 6 06:39 favicon.ico
    -rwxr--r-- 1 1072 600 774 May 6 06:39 gdform.php
    -rw-r--r-- 1 1072 600 324 May 6 17:40 index.html
    -rwx---r-x 1 1072 600 1683 May 6 06:39 missing.html
    -rwx---r-x 1 1072 600 389 May 6 06:39 php.ini
    drwxrwx--- 2 1072 600 4096 May 6 06:39 php_uploads
    drwx---r-x 2 0 0 4096 May 7 06:14 stats
    -rwx---r-x 1 1072 600 2839 May 6 06:39 welcome.html
    226-Options: -a -l
    226 12 matches total
    CWD Video Podcast
    550 Can't change directory to Video Podcast : No such file or directory
    MKD Video Podcast
    257 "Video Podcast_" : The directory was successfully created
    CWD Video Podcast
    550 Can't change directory to Video Podcast : No such file or directory
    MKD Video Podcast
    550 Can't create directory: File exists
    ftp_mkdir: 2,-30000 (state == RPUT_MAKING_DIR)
    PWD
    257 "/" is your current location
    PASV
    227 Entering Passive Mode (68,178,254,198,183,131)
    Making data connection to 68.178.254.198 port 46979
    LIST -al
    150 Accepted data connection
    drwx---r-x 7 1072 600 4096 May 7 13:26 .
    drwx---r-x 7 1072 600 4096 May 7 13:26 ..
    drwxr-xr-x 8 1072 600 4096 May 7 13:24 Huntin' Junky
    drwxr-xr-x 2 1072 600 4096 May 7 13:26 Video Podcast_
    drwx---r-x 2 1072 600 4096 May 6 06:39 cgi
    -rwx---r-x 1 1072 600 0 May 6 06:39 favicon.ico
    -rwxr--r-- 1 1072 600 774 May 6 06:39 gdform.php
    -rw-r--r-- 1 1072 600 324 May 6 17:40 index.html
    -rwx---r-x 1 1072 600 1683 May 6 06:39 missing.html
    -rwx---r-x 1 1072 600 389 May 6 06:39 php.ini
    drwxrwx--- 2 1072 600 4096 May 6 06:39 php_uploads
    drwx---r-x 2 0 0 4096 May 7 06:14 stats
    -rwx---r-x 1 1072 600 2839 May 6 06:39 welcome.html
    226-Options: -a -l
    226 13 matches total

    Posted 7 years ago #

  • Scott McGuire Administrator

    Hi,

    The transcript shows that when Fetch asked the server to create a folder named "Video Podcast" to hold your new webpage files, the server instead created a folder named "Video Podcast_" (with an underscore at the end). This is not normal. Then Fetch tries to upload files to the "Video Podcast" folder, which doesn't exist, because the server created a folder with a different name instead - so you get an error.

    This is very peculiar behavior, and not what we would normally expect a server to do.

    First, see my suggestion about extra spaces in the message following this one. Then come back here if necessary.

    If that doesn't help, this is what we suggest you try:

    * Connect to the server, and delete the "Video Podcast_" folder in the Fetch window.
    * Then try uploading your files again.

    If you run into the same problem again, the next thing you should try is to see if your server supports SFTP connections. Not all servers support SFTP, but if it does, you may be able to avoid this problem.

    To do this:

    * Choose "New Connection" from the "File" menu in Fetch.
    * Enter your connection information in Fetch's New Connection dialog as before, but choose SFTP from the "Connect using" pop-up menu.

    If Fetch takes forever to connect, or you get an error, your server does not support SFTP.

    If neither of these suggestions helps, we suggest you contact the folks who run your server and see if they can figure out what the problem is.

    Please let us know how it goes, and if we can answer any further questions.

    Thanks,

    Scott McGuire
    Fetch Softworks

    [This message has been edited by ScottMcGuire (edited 05-08-2007).]

    Posted 7 years ago #

  • Scott McGuire Administrator

    Hi Matt,

    Actually we have one more suggestion; please check this before you try the suggestions above.

    Make sure that there is not an extra space at the end of "Video Podcast" in iWeb (in the page title, or in iWeb sidebar). If there was, try exporting your site and uploading it again and see if that helps.

    If it doesn't, then try the suggestions above.

    Thanks,

    Scott McGuire
    Fetch Softworks

    Posted 7 years ago #

  • mattshort Member

    Thanks Scott!
    There was a space after Podcast in iweb. When I made my changes I created a new Podcast page and only deleted the '2' (iweb automatically puts in) after Podcast & not the space between. Everytime I changed the name of the Podcast page I never deleted the space. Thanks for the help. This was driving me nuts.
    Matt

    Posted 7 years ago #

  • Scott McGuire Administrator

    Hi Matt,

    Great, we're glad to hear that fixed it. Thanks for letting us know.

    Best,

    Scott McGuire
    Fetch Softworks

    Posted 7 years ago #

Reply

  • Or nickname, if you prefer.
  • This will be kept confidential.
  • This is to ensure that you’re a person, not a spambot.