Your best friend for file transfer.

Fetch application logoFetch

Proxy settings. (15 posts)

This is an archived topic. The information in it is likely to be out-of-date and no longer applicable to current versions of Fetch.
  • Started 13 years ago by pappy
  • Latest reply 13 years ago from Jim Matthews
  • pappy Member

    While I appreciate all the new options for proxy settings, I can't get any of them to work. What is the equivalent to the setting in Fetch 3.03 "Use proxy ftp server"?

    Posted 13 years ago #

  • Jim Matthews Administrator

    You want to use "USER with no logon". Sorry, that should be documented more clearly.

    Jim Matthews
    Fetch Softworks

    Posted 13 years ago #

  • Grant T Member

    I cannot get the proxy settings to work either. I can connect through my firewall with Fetch 3.03 using a SOCKS gateway which has a port number 1080. In 3.03 there is a range for port settings, in 4 there is a box for the number but it will not stay there - come back to the preferences and the box is empty. (I have no idea at all what a SOCKS gateway might be, by the way.) Trying to connect gives me error -1.

    Posted 13 years ago #

  • colin Member

    I am having the same problem (port settings disappearing). Will this be fixed in the next version of Fetch or am I doing something wrong?

    Posted 13 years ago #

  • Jim Matthews Administrator

    I'm not sure why connections aren't working, but at least I can explain the disappearing port number. 1080 is the standard port for SOCKS, and Fetch only displays the port number if it's non-standard.

    As for the -1 error, what are the settings in the Firewall section of Preferences?

    Posted 13 years ago #

  • Grant T Member

    Well, I was about to reply that I had tried them all - ie all those that didn't require a password or ID - just thought I'd go and run through them again to make sure and - it works! Using Socks 4, PASV and no port number.

    Thanks for the help.

    I think when you are charging for this, users will need a little more help with these preferences. Making the port number just disappear if it's standard is not exactly intuitive to me.

    Posted 13 years ago #

  • Grant T Member

    Spoke too soon. It only sort of works, but seems to have trouble (never manages to complete getting file list) opening sub-directories in my site - which 3.03 opens without hesitation.
    If I quit when it gets stuck, and then try again, it usually opens the directory without hesitation the second time.
    Another oddity: I tried setting some of the other SOCKS options but it always reverts back to 4.
    (To tell the truth, I wouldn't be here at all if I could get Dreamweaver 3 to ftp through our firewall...)

    Posted 13 years ago #

  • Jim Matthews Administrator

    Do you know what kind of firewall it is?

    You mention that the proxy type setting goes back to SOCKS 4. Does this happen every time you try to change it? Do you have to quit Fetch for it to switch back, or does it switch immediately?

    Thanks for your help.

    Posted 13 years ago #

  • Burtcom Member

    I'm seeing problems with Proxy too. Fetch 3.0.3 worked great with a SOCKS proxy, but 4.0b5 does the following.

    * Changing the SOCKS type doesn't work, as it reverts to the previous type immediately.

    * Selecting a proxy in Fetch ALSO sets a proxy in my Miccrosoft Explorer! IE then tries to connect HTTP via the proxy, which of course I don't want it to.

    * I either get an error 1, or a connection with no directory listing.

    Posted 13 years ago #

  • Burtcom Member

    I should point out I'm trying to connect to a NT 4 server running IIS. With SOCKS proxy disabled I get connected but with no directory listing. With SOCKS enabled I get an error. Fetch 3 works fine in both situations.

    Posted 13 years ago #

  • Jim Matthews Administrator

    * Changing the SOCKS type doesn't work, as it reverts to the previous type immediately.

    I just found that bug; it will be fixed in the next beta.

    * Selecting a proxy in Fetch ALSO sets a proxy in my Microsoft Explorer!

    If "Use Internet Config" is checked (in the General section of Preferences) then Fetch will save the SOCKS setting to Internet Config (aka the Internet Control Panel), which MS IE also uses. The workaround is to uncheck that box, so that Fetch and MS IE can have different SOCKS settings.

    I would be interested in seeing a transcript of a session with 4.0b5 (choose "Fetch Transcript" from the Windows menu). Do you know what kind of proxy you are connecting through?

    Thanks for the feedback,

    Jim Matthews
    Fetch Softworks

    Posted 13 years ago #

  • Burtcom Member

    Jim, here's the transcript for when I get a connection through Proxy, but no directory listing shows up.

    The proxy I'm using is Proxyvailable at http://www.proxyplus.cz This works great with Fetch 3.

    ----------
    NOT_CONNECTED -> NOT_CONNECTED 0
    NOT_CONNECTED -> NOT_CONNECTED 0
    fwp.state.mt.us NOT_CONNECTED -> CONNECTING 0
    Connecting to fwp.state.mt.us port 21 (2/15/01 3:46:13 PM)
    220 web1 Microsoft FTP Service (Version 4.0).
    ADAT
    500 'ADAT Hi there, do you support security?': command not understood
    USER usernamedeleted
    331 Password required for usernamedeleted.
    PASS
    230 User usernamedeleted logged in.
    fwp.state.mt.us CONNECTING -> SENDING_PBSZ 0
    fwp.state.mt.us SENDING_PBSZ -> SENDING_PROT 0
    fwp.state.mt.us SENDING_PROT -> GETTING_INFO 0
    SYST
    215 Windows_NT version 4.0
    PWD
    257 "/" is current directory.
    MACB ENABLE
    500 'MACB ENABLE': command not understood
    SITE DIRSTYLE
    200 MSDOS-like directory output is on
    SITE DIRSTYLE
    200 MSDOS-like directory output is off
    fwp.state.mt.us GETTING_INFO -> GETTING_WD 0
    PWD
    257 "/" is current directory.
    fwp.state.mt.us GETTING_WD -> GETTING_WD 0
    PWD
    257 "/" is current directory.
    fwp.state.mt.us GETTING_WD -> GETTING_LIST 0
    PASV
    227 Entering Passive Mode (161,7,137,11,8,134).
    LIST
    125 Data connection already open; Transfer starting.
    226 Transfer complete.
    fwp.state.mt.us GETTING_LIST -> IDLE 0
    fwp.state.mt.us IDLE -> TICKLING 0
    NOOP
    200 NOOP command successful.
    fwp.state.mt.us TICKLING -> IDLE 0
    --------

    Posted 13 years ago #

  • smindeaux Member

    Hi there. I have been having problems loggin into our proxy server. I have my settings all set in the Internet control panel and I do get in. I authenitcate into our proxyserver. However, our server then wants the following command:

    user loginname@ftp.server.com

    I've entered all the information in the fields, but how do I get Fetch to pass that command? A dialog box comes up saying that Permission is denied.

    Posted 13 years ago #

  • Jim Matthews Administrator

    Burtcom:

    I checked the Proxyebsite, and it appears that it does not support the PASV command. So try unchecking the "Use passive mode transfers (PASV)" box in the Firewall section of Preferences -- does that work?

    Posted 13 years ago #

  • Jim Matthews Administrator

    smindeaux:

    Could you post the contents of the Fetch Transcript widnow (listed in the Windows menu) after you get the Permission Denied error?

    Thanks.

    Posted 13 years ago #

Topic closed

This topic has been closed.