Your best friend for file transfer.

Fetch application logoFetch

Upload nets me 'pureftpd.445123'...etc. (13 posts)

  • Started 8 years ago by suzie hammond
  • Latest reply 7 years ago from Scott McGuire
  • suzie hammond Member

    Been using 5.0.2 and had no problems. Went to upload a new webpage version and get " pureftpd.445303.1" etc for almost all documents. (differing #'s for each doc and there are several dozens)

    When it uploads it says it is uploading 'image_345.png' or whatever the correct title is but on the server after process is complete it gives me this pureftpd and nothing opens correctly.

    Upgraded to 5.0.5 and still no joy. Then uninstalled everything I could find, restarted and reinstalled 5.0.5. Still no joy and it gives me this problem for anything I try to upload.

    What gives? I am in deep trouble with deadlines here, naturally.

    Thanks for any help
    Suzie

    Posted 8 years ago #

  • Scott McGuire Administrator

    Hi Suzie,

    When you use the Put command, check to see what the setting of the "If a file already exists:" menu in the Put dialog is. If it says "Pick a different name", this may be the problem. Try changing it to "Replace existing file" and see if that fixes the problem.

    When this menu is set to "Pick a different name", Fetch asks the server to give your file a unique name to make sure it does not replace an existing file. Unfortunately, the unique names some servers give the files are nonsense names, like the ones you're seeing. And if you're uploading a new version of a webpage, you probably want to replace the existing files anyway.

    Let us know if this does not fix the problem. If not, we'll investigate further.

    Thanks,

    Scott McGuire
    Fetch Softworks

    Posted 8 years ago #

  • 89thFifer Member

    I am also having the same problem. I tried changing to "replace existig file" as recommended, and this stopped the filename getting changed to "pureftp...." However, the data I am trying to upload is still getting corrupted and therefore the page does not display properly. What can I do to correct this?

    Thanks!! :)

    Posted 8 years ago #

  • suzie hammond Member

    I had a similar problem when I tried the fix. I found I had to go back and make sure my files were correctly named without spaces between words, etc. My layout had given the file names "April Newsletter" etc. it had to be changed to aprilnews.....or some such...now it seems to work perfectly.

    Thanks Scott

    Posted 8 years ago #

  • Scott McGuire Administrator

    Suzie, you're welcome, and we're glad to hear that fixed the problem.

    89thFifer, if Suzie's suggestion doesn't fix the problems you're seeing, let us know and we'll investigate further.

    Thanks,

    Scott McGuire
    Fetch Softworks

    Posted 8 years ago #

  • 89thFifer Member

    Hi!

    I made sure there were no spaces in my filenames, but data is still getting corrupted when I upload.

    Thanks ahead of time for your help!

    :)

    Posted 8 years ago #

  • Scott McGuire Administrator

    Hi 89thFifer,

    We'd like some more information to help diagnose the problem.

    Could you please upload one of the files that gets corrupted on upload, and then choose Fetch Transcript from the Window menu, copy the entire contents of the transcript window, and paste them here? We'll take a look and try to figure out what's going on.

    Also, can you describe in what way the files are being corrupted?

    Thanks,

    Scott McGuire
    Fetch Softworks

    [This message has been edited by ScottMcGuire (edited 04-26-2006).]

    Posted 8 years ago #

  • 89thFifer Member

    Hi!

    When I upload my html code, a lot of gobbledygook gets added at the beginning and end. Also, when I try to link to images on another page of the web site, portions of the location references get deleted so that the images do not display properly. Sometimes centering commands also get deleted. I generally have a better time with plain text.

    The Fetch transcript is below.

    Thanks again for your help! :)
    89thFifer

    Fetch 5.0.5 (5A835) PowerPC running on Mac OS X 10.2.6 (6L60) PowerPC English
    StuffIt Engine 0x700, StuffIt SDK Version StuffIt version 7.0
    Partial serial FETCH5X001-FW7Q-L4SR T
    Connecting to ftp.uppercanadianheritage.com port 21 (OS X firewall is off) (4/28/06 6:20:01 PM)
    Connected to 72.29.75.167 port 21 (4/28/06 6:20:01 PM)
    220---------- Welcome to Pure-FTPd [TLS] ----------
    220-You are user number 2 of 50 allowed.
    220-Local time is now 18:20. Server port: 21.
    220 You will be disconnected after 15 minutes of inactivity.
    ADAT
    500 This security scheme is not implemented
    AUTH This command is checking whether this server supports Kerberos or GSS security, see RFC 2228
    500 This security scheme is not implemented
    USER the89th@psican.org
    331 User the89th@psican.org OK. Password required
    PASS
    230-User the89th@psican.org has group access to: ghrs
    230-OK. Current restricted directory is /
    230 757 Kbytes used (0%) - authorized: 358400 Kb
    SYST
    215 UNIX Type: L8
    PWD
    257 "/" is your current location
    MACB ENABLE
    500 Unknown command
    PWD
    257 "/" is your current location
    TYPE A
    200 TYPE is now ASCII
    PASV
    227 Entering Passive Mode (72,29,75,167,182,166)
    LIST -al
    150 Accepted data connection
    drwxr-xr-x 4 32181 ghrs 4096 Apr 28 18:12 .
    drwxr-xr-x 4 32181 ghrs 4096 Apr 28 18:12 ..
    -rw------- 1 32181 ghrs 10 Apr 28 18:12 .ftpquota
    -rw-r--r-- 1 32181 ghrs 25164 Nov 2 20:53 camp.jpg
    drwxr-xr-x 2 32181 ghrs 4096 Nov 2 20:31 cgi-bin
    -rw-r--r-- 1 32181 ghrs 779 Apr 20 19:35 contacts.html
    -rw-r--r-- 1 32181 ghrs 956 Mar 28 18:17 events.html
    -rw-r--r-- 1 32181 ghrs 781 Apr 18 18:50 fgcamp.html
    -rw-r--r-- 1 32181 ghrs 784 Apr 18 18:50 fgcolours.html
    -rw-r--r-- 1 32181 ghrs 791 Apr 18 18:50 fgfearlessleader.html
    -rw-r--r-- 1 32181 ghrs 787 Apr 18 18:50 fgnightscene.html
    -rw-r--r-- 1 32181 ghrs 782 Apr 18 18:50 fgscott.html
    -rw-r--r-- 1 32181 ghrs 785 Apr 18 18:50 fgsunrise1.html
    -rw-r--r-- 1 32181 ghrs 785 Apr 18 18:50 fgsunrise2.html
    -rw-r--r-- 1 32181 ghrs 782 Apr 18 18:50 fgterry.html
    -rw-r--r-- 1 32181 ghrs 1468 Apr 20 09:19 fortgeorge.html
    -rw-r--r-- 1 32181 ghrs 808 Mar 28 18:17 history.html
    drwxr-xr-x 2 32181 ghrs 4096 Apr 19 22:33 images
    -rw-r--r-- 1 32181 ghrs 1142 Mar 28 18:13 index.html
    -rw-r--r-- 1 32181 ghrs 777 Mar 28 18:17 links.html
    -rw-r--r-- 1 32181 ghrs 844 Apr 20 09:19 longwoods.html
    -rw-r--r-- 1 32181 ghrs 32530 Nov 2 20:53 marching.jpg
    -rw-r--r-- 1 32181 ghrs 923 Apr 20 19:36 pictures.html
    -rw-r--r-- 1 32181 ghrs 826 Mar 28 18:17 recruitment.html
    -rw-r--r-- 1 32181 ghrs 743 Apr 20 19:37 stoneycreek.html
    -rw-r--r-- 1 32181 ghrs 511 Nov 2 20:27 stylesheet.css
    -rw-r--r-- 1 32181 ghrs 25261 Apr 28 18:12 test.html
    226-Options: -a -l
    226 27 matches total
    TYPE I
    200 TYPE is now 8-bit binary
    PASV
    227 Entering Passive Mode (72,29,75,167,186,193)
    STOR test.html
    150 Accepted data connection
    226-757 Kbytes used (0%) - authorized: 358400 Kb
    226-File successfully transferred
    226 4.807 seconds (measured here), 5.13 Kbytes per second
    Transfer of test.html (25,261 bytes, 6,315 bytes/sec, 0:04 elapsed) completed at 4/28/06 6:20:29 PM
    PWD
    257 "/" is your current location
    Update check skipped at 04/28/2006 06:21 PM (next check after 05/05/2006 02:34 PM)
    PWD
    257 "/" is your current location
    PWD
    257 "/" is your current location
    PWD
    257 "/" is your current location
    PWD
    257 "/" is your current location

    Posted 7 years ago #

  • Scott McGuire Administrator

    Hi 89thFifer,

    Thanks for the transcript.

    If you go to the Format submenu of the Remote menu, which item is checked currently? It is "Automatic" or something else?

    Try selecting "Text" from the Format menu and then uploading the HTML file and see if that fixes the problem.

    Thanks,

    Scott McGuire
    Fetch Softworks

    Posted 7 years ago #

  • 89thFifer Member

    Hi Scott,

    I tried selecting Text in the Format menu (I've also tried it as Binary) but it doesn't make any difference.

    I have been writing my code in Appleworks and then when I go to upload it, I change the file extension from .cwk to .html Could that be causing the problem? The only other thing I can think of is that the web site I am trying to update was originally created by someone else using a Windows machine. I don't know if that makes a difference or not?

    Sorry to be such a pain. Thanks so much for your help!! :)

    89thFifer

    Posted 7 years ago #

  • Scott McGuire Administrator

    Originally posted by 89thFifer:

    I have been writing my code in Appleworks and then when I go to upload it, I change the file extension from .cwk to .html Could that be causing the problem?

    Yes, that would explain what you're seeing. Appleworks files are not HTML files, so just changing the extension will not do the correct thing.

    Are you writing raw HTML in Appleworks, or are you creating formatted text in Appleworks that you want to save as HTML?

    If you're writing raw HTML code (which it sounds like you are), in AppleWorks, when you want to save your file and upload it to your website, you should choose File > Save As, and select "Text" from the File Format pop-up. Then add or change the extension to HTML. You may have to remember to do this every time you re-open the file and make changes, because Appleworks likes to converts text files back to Appleworks format when it opens them.

    In general, Appleworks isn't a very good program to use for HTML editing. If you are writing in raw HTML, consider using the free text editor Textwrangler from Bare Bones Software - see <http://www.barebones.com/products/textwrangler/> . That way you won't have to worry about resaving your files in the right format, they'll always be text and ready for uploading without extra gunk. (There are several other good, free text editors on the Macintosh as well.)

    If you're creating formatting documents in Appleworks and want to save them as HTML, I can explain some of the gotchas in doing that.

    Hope this helps,

    Scott McGuire
    Fetch Softworks

    Posted 7 years ago #

  • 89thFifer Member

    Hi Scott,

    Problem solved! :) Thanks so much for your help!!

    89thFifer

    Posted 7 years ago #

  • Scott McGuire Administrator

    Hi 89thFifer,

    Great, glad to hear it's sorted out.

    Please let us know if you have any more questions.

    Scott McGuire
    Fetch Softworks

    Posted 7 years ago #

Reply

  • Or nickname, if you prefer.
  • This will be kept confidential.
  • This is to ensure that you’re a person, not a spambot.